summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorpaul <paul>2003-10-24 04:24:39 +0000
committerpaul <paul>2003-10-24 04:24:39 +0000
commitff7c65cf6ae73d1f02ee7f8fe44e51413c569b3b (patch)
tree1d16c4833f19afaec4f5cdf5cb46a71546691f69 /configure.ac
parent0d5bcd5a8717cecd94d36447c7ae5072a2a6bb6c (diff)
downloadquagga-ff7c65cf6ae73d1f02ee7f8fe44e51413c569b3b.tar.bz2
quagga-ff7c65cf6ae73d1f02ee7f8fe44e51413c569b3b.tar.xz
2003-10-24 Paul Jakma <paul@dishone.st>
* configure.ac: Check for fcntl() * {bgpd,ospf,ospf6d,ripd,ripngd}/Makefile.am: Install conf file via regular automake means, not magic install incantations, see bug #38. * lib/Makefile.am: install the headers, needed to link libzebra.a (and hence libospf.a, OSPF-API, etc.)
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac3
1 files changed, 2 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 807cf7c0..26079882 100755
--- a/configure.ac
+++ b/configure.ac
@@ -345,7 +345,8 @@ dnl ----------------------------
dnl check existance of functions
dnl ----------------------------
AC_CHECK_FUNCS(memset memcpy strerror inet_aton daemon snprintf vsnprintf \
- strlcat strlcpy if_nametoindex if_indextoname getifaddrs)
+ strlcat strlcpy if_nametoindex if_indextoname getifaddrs \
+ fcntl)
AC_CHECK_FUNCS(setproctitle, ,
[AC_CHECK_LIB(util, setproctitle,
[LIBS="$LIBS -lutil"