summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorhasso <hasso>2005-03-28 15:29:07 +0000
committerhasso <hasso>2005-03-28 15:29:07 +0000
commit2b8c6f84fe15075d9bcc2a0966b6d5dbb4f7f4c2 (patch)
tree67788e4e9956882a6d8ccb94b1289f616579342c /configure.ac
parentb563c7d98ba277ce29ded67fe9265428298aefec (diff)
downloadquagga-2b8c6f84fe15075d9bcc2a0966b6d5dbb4f7f4c2.tar.bz2
quagga-2b8c6f84fe15075d9bcc2a0966b6d5dbb4f7f4c2.tar.xz
* configure.ac, */Makefile.am: Fix previous commit. SNMP includes
must be after lib/ includes in some systems. Introduce SNMP_INCLUDES for that.
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac12
1 files changed, 7 insertions, 5 deletions
diff --git a/configure.ac b/configure.ac
index d8e5e5cb..13e8cca7 100755
--- a/configure.ac
+++ b/configure.ac
@@ -948,7 +948,7 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
AC_DEFINE(HAVE_SNMP,,SNMP)
AC_DEFINE(HAVE_NETSNMP,,SNMP)
AC_DEFINE(UCD_COMPATIBLE,,SNMP)
- INCLUDES="${INCLUDES} -I/usr/include/net-snmp -I/usr/include/net-snmp/library"
+ SNMP_INCLUDES="${SNMP_INCLUDES} -I/usr/include/net-snmp -I/usr/include/net-snmp/library"
if test "${HAVE_NETSNMP}" = "yes"; then
LIBS="${LIBS} -lnetsnmp"
else
@@ -957,19 +957,19 @@ dnl AC_CHECK_LIB(snmp, asn_parse_int, HAVE_SNMP=yes)
;;
/usr/include/ucd-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
- INCLUDES="${INCLUDES} -I/usr/include/ucd-snmp"
+ SNMP_INCLUDES="${SNMP_INCLUDES} -I/usr/include/ucd-snmp"
LIBS="${LIBS} -lsnmp"
;;
/usr/local/include/ucd-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
- INCLUDES="${INCLUDES} -I/usr/local/include/ucd-snmp"
+ SNMP_INCLUDES="${SNMP_INCLUDES} -I/usr/local/include/ucd-snmp"
LIBS="${LIBS} -L/usr/local/lib -lsnmp"
;;
/usr/local/include/net-snmp/*)
AC_DEFINE(HAVE_SNMP,,SNMP)
AC_DEFINE(HAVE_NET_SNMP,,SNMP)
AC_DEFINE(UCD_COMPATIBLE,,SNMP)
- INCLUDES="${INCLUDES} -I/usr/local/include/net-snmp"
+ SNMP_INCLUDES="${SNMP_INCLUDES} -I/usr/local/include/net-snmp"
LIBS="${LIBS} -L/usr/local/lib -lnetsnmp"
;;
esac
@@ -983,6 +983,8 @@ if test "${enable_snmp}" = "yes" -a "${HAVE_SNMP}" != "yes"; then
AC_MSG_ERROR([--enable-snmp given, but cannot find support for SNMP])
fi
+AC_SUBST(SNMP_INCLUDES)
+
dnl ----------------------------
dnl check sa_len of sockaddr
dnl ----------------------------
@@ -1280,7 +1282,7 @@ host operationg system : ${host_os}
source code location : ${srcdir}
compiler : ${CC}
compiler flags : ${CFLAGS}
-includes : ${INCLUDES}
+includes : ${INCLUDES} ${SNMP_INCLUDES}
linker flags : ${LDFLAGS} ${LIBS}
state file directory : ${quagga_statedir}
config file directory : `eval echo \`echo ${sysconfdir}\``