summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorvincent <vincent>2005-03-25 13:05:47 +0000
committervincent <vincent>2005-03-25 13:05:47 +0000
commit7442f4c317846e06567feab31afdfe9158bb94c4 (patch)
tree3ef4f5d2c89d573cd61c8081bde7aaa6ab396070 /configure.ac
parent7399edc0a5988068d636476153786c1ccfd213fd (diff)
downloadquagga-7442f4c317846e06567feab31afdfe9158bb94c4.tar.bz2
quagga-7442f4c317846e06567feab31afdfe9158bb94c4.tar.xz
2005-03-25 Jean-Mickael Guerin <jean-mickael.guerin@6wind.com>
* Extensions to Neighbor Discovery for Mobile IPv6
Diffstat (limited to 'configure.ac')
-rwxr-xr-xconfigure.ac30
1 files changed, 30 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 6caf9dcd..aa7f445b 100755
--- a/configure.ac
+++ b/configure.ac
@@ -1073,6 +1073,36 @@ AC_TRY_COMPILE([#include <netinet/in.h>
AC_DEFINE(HAVE_INPKTINFO,,in_pktinfo)],
AC_MSG_RESULT(no))
+dnl ----------------------------------
+dnl check struct nd_opt_homeagent_info
+dnl ----------------------------------
+AC_MSG_CHECKING(whether struct nd_opt_homeagent_info exist)
+AC_EGREP_HEADER(nd_opt_homeagent_info,
+netinet/icmp6.h,
+[AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_ND_OPT_HOMEAGENT_INFO,,nd_opt_homeagent_info)],
+ AC_MSG_RESULT(no))
+
+dnl --------------------------------
+dnl check struct nd_opt_adv_interval
+dnl --------------------------------
+AC_MSG_CHECKING(whether struct nd_opt_adv_interval exist)
+AC_EGREP_HEADER(nd_opt_adv_interval,
+netinet/icmp6.h,
+[AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_ND_OPT_ADV_INTERVAL,,nd_opt_adv_interval)],
+ AC_MSG_RESULT(no))
+
+dnl ------------------------------------
+dnl check fields in nd_opt_adv_interval
+dnl ------------------------------------
+AC_MSG_CHECKING(whether nd_opt_ai_type field exist)
+AC_EGREP_HEADER(nd_opt_ai_type,
+netinet/icmp6.h,
+[AC_MSG_RESULT(yes)
+ AC_DEFINE(HAVE_ND_OPT_ADV_INTERVAL_AI_FIELDS,,nd_opt_ai_type)],
+ AC_MSG_RESULT(no))
+
dnl --------------------------------------
dnl checking for getrusage struct and call
dnl --------------------------------------