summaryrefslogtreecommitdiffstats
path: root/nhrpd/Makefile.am
diff options
context:
space:
mode:
authorTimo Teräs <timo.teras@iki.fi>2015-12-25 10:32:11 +0200
committerTimo Teräs <timo.teras@iki.fi>2016-03-30 16:59:22 +0300
commit068e64859913c6844bbe6703815a633175650547 (patch)
tree3efc0440477560ac6211f9da3bea3f812bb05270 /nhrpd/Makefile.am
parent76aaa0456a3804a0a1d2948d9a391383b62cbe37 (diff)
downloadquagga-068e64859913c6844bbe6703815a633175650547.tar.bz2
quagga-068e64859913c6844bbe6703815a633175650547.tar.xz
initial implementation of nhrpnhrp
this is nhrp changes from commit c321432aef01e13116980983f0a50ba486505804 rebased on quagga master and updated for vrf changes
Diffstat (limited to 'nhrpd/Makefile.am')
-rw-r--r--nhrpd/Makefile.am34
1 files changed, 34 insertions, 0 deletions
diff --git a/nhrpd/Makefile.am b/nhrpd/Makefile.am
new file mode 100644
index 00000000..d7e9e3a9
--- /dev/null
+++ b/nhrpd/Makefile.am
@@ -0,0 +1,34 @@
+## Process this file with automake to produce Makefile.in.
+
+AM_CPPFLAGS = -I.. -I$(top_srcdir) -I$(top_srcdir)/lib -I$(top_builddir)/lib -DQUAGGA_NO_DEPRECATED_INTERFACES
+DEFS = @DEFS@ @CARES_CFLAGS@ -DSYSCONFDIR=\"$(sysconfdir)/\"
+INSTALL_SDATA=@INSTALL@ -m 600
+
+AM_CFLAGS = $(PICFLAGS) #$(WERROR)
+AM_LDFLAGS = $(PICLDFLAGS)
+
+sbin_PROGRAMS = nhrpd
+
+nhrpd_SOURCES = \
+ zbuf.c \
+ znl.c \
+ resolver.c \
+ linux.c \
+ netlink.c \
+ vici.c \
+ reqid.c \
+ nhrp_event.c \
+ nhrp_packet.c \
+ nhrp_interface.c \
+ nhrp_vc.c \
+ nhrp_peer.c \
+ nhrp_cache.c \
+ nhrp_nhs.c \
+ nhrp_route.c \
+ nhrp_shortcut.c \
+ nhrp_vty.c \
+ nhrp_main.c
+
+nhrpd_LDADD = ../lib/libzebra.la @LIBCAP@ @CARES_LIBS@
+
+#dist_examples_DATA = nhrpd.conf.sample