aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2010-03-05 13:11:58 +0100
committerTobias Brunner <tobias@strongswan.org>2010-03-05 14:46:59 +0100
commit807c12ce669b8e00188a60ce8ea448f8b05b9167 (patch)
tree733a2565b168a2c1ffbe8fda9cf11c4e4d95d89b /Makefile.am
parent0ace35282cf6840f63e6704a1737ca3fb210fac4 (diff)
downloadstrongswan-807c12ce669b8e00188a60ce8ea448f8b05b9167.tar.bz2
strongswan-807c12ce669b8e00188a60ce8ea448f8b05b9167.tar.xz
Generate the main Android.mk, so the version number is not hardcoded.
We include the generated file in the distribution, so users won't have run configure if they are building for Android.
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/Makefile.am b/Makefile.am
index 53b14593e..da79e557c 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,8 +6,15 @@ endif
ACLOCAL_AMFLAGS = -I m4/config
-EXTRA_DIST = Doxyfile.in CREDITS Android.mk
+EXTRA_DIST = Doxyfile.in CREDITS Android.mk.in Android.mk
CLEANFILES = apidoc Doxyfile
+BUILT_SOURCES = Android.mk
+MAINTAINERCLEANFILES = Android.mk
+
+Android.mk : Android.mk.in
+ sed \
+ -e "s:\@PACKAGE_VERSION\@:$(PACKAGE_VERSION):" \
+ $(srcdir)/$@.in > $@
Doxyfile : Doxyfile.in
sed \