aboutsummaryrefslogtreecommitdiffstats
path: root/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2015-04-16 14:37:16 +0200
committerMartin Willi <martin@revosec.ch>2015-04-16 15:28:37 +0200
commit882c993b8937303f540605811b0bfd090b4f3ca1 (patch)
treef297ac6cbb25d9fc712dd719954160799e539ec1 /Makefile.am
parent377f13f794d25a5079e4d38ecbedc74b73a8f938 (diff)
downloadstrongswan-882c993b8937303f540605811b0bfd090b4f3ca1.tar.bz2
strongswan-882c993b8937303f540605811b0bfd090b4f3ca1.tar.xz
apidoc: Conditionally run doxygen if any header/Markdown files have changed
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 4 insertions, 2 deletions
diff --git a/Makefile.am b/Makefile.am
index bea4ba7c0..f9e6452a2 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -38,7 +38,9 @@ Doxyfile : Doxyfile.in
$(srcdir)/$@.in > $@
apidoc : Doxyfile
- doxygen
+ @test -d apidoc || doxygen
+ @! find Doxyfile src/ -name '*.h' -o -name '*.md' , -newer apidoc | \
+ grep -q '' || doxygen && touch apidoc
cov-reset-common:
@rm -rf $(top_builddir)/coverage
@@ -75,4 +77,4 @@ clean-local: cov-reset-common
@find $(top_builddir)/src $(top_builddir)/scripts -name "*.gcno" -delete
@rm -rf apidoc
-.PHONY: cov-reset-common cov-reset cov-report coverage
+.PHONY: cov-reset-common cov-reset cov-report coverage apidoc