aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2008-04-22 08:44:56 +0000
committerMartin Willi <martin@strongswan.org>2008-04-22 08:44:56 +0000
commit36d62fac65f5e079d551d3aa18e2c4d2a8551b2b (patch)
treea2fade6fa5af4ac9d9e39c3dd1b75c8f47285385 /configure.in
parent65456bfe330ae9604e7f3b76cd01d66cfcf751b2 (diff)
downloadstrongswan-36d62fac65f5e079d551d3aa18e2c4d2a8551b2b.tar.bz2
strongswan-36d62fac65f5e079d551d3aa18e2c4d2a8551b2b.tar.xz
experimental Padlock plugin supportin SHA1 and AES-128 for VIA C7 Esther
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index 26c3e5369..9ec34b878 100644
--- a/configure.in
+++ b/configure.in
@@ -486,6 +486,16 @@ AC_ARG_ENABLE(
tools=true
)
+AC_ARG_ENABLE(
+ [padlock],
+ AS_HELP_STRING([--enable-padlock],[enables VIA Padlock crypto plugin. (default is NO).]),
+ [if test x$enableval = xyes; then
+ padlock=true
+ else
+ padlock=false
+ fi],
+)
+
dnl =========================
dnl check required programs
dnl =========================
@@ -632,6 +642,7 @@ AM_CONDITIONAL(USE_TOOLS, test x$tools = xtrue)
AM_CONDITIONAL(USE_PLUTO_OR_CHARON, test x$pluto = xtrue -o x$charon = xtrue)
AM_CONDITIONAL(USE_LIBSTRONGSWAN, test x$charon = xtrue -o x$tools = xtrue)
AM_CONDITIONAL(USE_FILE_CONFIG, test x$pluto = xtrue -o x$stroke = xtrue)
+AM_CONDITIONAL(USE_PADLOCK, test x$padlock = xtrue)
dnl ==============================
dnl set global definitions
@@ -664,6 +675,7 @@ AC_OUTPUT(
src/libstrongswan/plugins/ldap/Makefile
src/libstrongswan/plugins/mysql/Makefile
src/libstrongswan/plugins/sqlite/Makefile
+ src/libstrongswan/plugins/padlock/Makefile
src/libcrypto/Makefile
src/libfreeswan/Makefile
src/pluto/Makefile