aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2008-09-02 11:04:26 +0000
committerMartin Willi <martin@strongswan.org>2008-09-02 11:04:26 +0000
commit21c95463211d8bfe987263299a82492975c28831 (patch)
tree8ed150ae62c2c42b7499613a984b3f5a3b003432 /configure.in
parent46eb41644d665d6ad05bb489a8b5ff505ff04256 (diff)
downloadstrongswan-21c95463211d8bfe987263299a82492975c28831.tar.bz2
strongswan-21c95463211d8bfe987263299a82492975c28831.tar.xz
libstrongswan agent plugin to use ssh-agent for RSA signatures
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in15
1 files changed, 15 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index c3dd7280f..ea86c59e5 100644
--- a/configure.in
+++ b/configure.in
@@ -572,6 +572,16 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [agent],
+ AS_HELP_STRING([--enable-agent],[enables the ssh-agent signing plugin. (default is NO).]),
+ [if test x$enableval = xyes; then
+ agent=true
+ else
+ agent=false
+ fi],
+)
+
+AC_ARG_ENABLE(
[uci],
AS_HELP_STRING([--enable-uci],[enable OpenWRT UCI configuration plugin (default is NO).]),
[if test x$enableval = xyes; then
@@ -793,6 +803,9 @@ fi
if test x$openssl = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" openssl"
fi
+if test x$agent = xtrue; then
+ libstrongswan_plugins=${libstrongswan_plugins}" agent"
+fi
if test x$gmp = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" gmp"
fi
@@ -823,6 +836,7 @@ AM_CONDITIONAL(USE_MYSQL, test x$mysql = xtrue)
AM_CONDITIONAL(USE_SQLITE, test x$sqlite = xtrue)
AM_CONDITIONAL(USE_PADLOCK, test x$padlock = xtrue)
AM_CONDITIONAL(USE_OPENSSL, test x$openssl = xtrue)
+AM_CONDITIONAL(USE_AGENT, test x$agent = xtrue)
dnl charon plugins
dnl ==============
@@ -900,6 +914,7 @@ AC_OUTPUT(
src/libstrongswan/plugins/sqlite/Makefile
src/libstrongswan/plugins/padlock/Makefile
src/libstrongswan/plugins/openssl/Makefile
+ src/libstrongswan/plugins/agent/Makefile
src/libstrongswan/fips/Makefile
src/libcrypto/Makefile
src/libfreeswan/Makefile