aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2012-04-20 14:58:02 +0200
committerTobias Brunner <tobias@strongswan.org>2012-08-08 15:30:27 +0200
commit224ab4c59b2b747f0ff1298dbb196ebfca561dca (patch)
treee35bff883def9311c2618b3768399630f986d945 /configure.in
parentb223d517c80924ee664238a48058d791e2d87c43 (diff)
downloadstrongswan-224ab4c59b2b747f0ff1298dbb196ebfca561dca.tar.bz2
strongswan-224ab4c59b2b747f0ff1298dbb196ebfca561dca.tar.xz
socket-default plugin allocates random ports if configured to 0.
Also added strongswan.conf options to change the ports.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in6
1 files changed, 3 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 5ee3b8723..3a7d5b76c 100644
--- a/configure.in
+++ b/configure.in
@@ -73,7 +73,7 @@ AC_ARG_WITH(
AC_ARG_WITH(
[charon-udp-port],
- AS_HELP_STRING([--with-charon-udp-port=port],[UDP port used by charon locally (default 500).]),
+ AS_HELP_STRING([--with-charon-udp-port=port],[UDP port used by charon locally (default 500). Set to 0 to allocate randomly.]),
[AC_DEFINE_UNQUOTED(CHARON_UDP_PORT, [$withval], [UDP port used by charon locally])
AC_SUBST(charon_udp_port, [$withval])],
[AC_SUBST(charon_udp_port, 500)]
@@ -81,14 +81,14 @@ AC_ARG_WITH(
AC_ARG_WITH(
[charon-natt-port],
- AS_HELP_STRING([--with-charon-natt-port=port],[UDP port used by charon locally in case a NAT is detected (must be different from charon-udp-port, default 4500)]),
+ AS_HELP_STRING([--with-charon-natt-port=port],[UDP port used by charon locally in case a NAT is detected (must be different from charon-udp-port, default 4500). Set to 0 to allocate randomly.]),
[AC_DEFINE_UNQUOTED(CHARON_NATT_PORT, [$withval], [UDP post used by charon locally in case a NAT is detected])
AC_SUBST(charon_natt_port, [$withval])],
[AC_SUBST(charon_natt_port, 4500)]
)
AC_MSG_CHECKING([configured UDP ports ($charon_udp_port, $charon_natt_port)])
-if test x$charon_udp_port == x$charon_natt_port; then
+if test x$charon_udp_port != x0 -a x$charon_udp_port = x$charon_natt_port; then
AC_MSG_ERROR(the ports have to be different)
else
AC_MSG_RESULT(ok)