aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2008-04-28 16:43:30 +0000
committerMartin Willi <martin@strongswan.org>2008-04-28 16:43:30 +0000
commita47486b5e4386b85c0a01424ba83930af8593ccc (patch)
tree154ab6a41116c1acb054a39ace0b6863ea8ab692 /configure.in
parente8a680d94a541bba152a45422580930fbdcee8eb (diff)
downloadstrongswan-a47486b5e4386b85c0a01424ba83930af8593ccc.tar.bz2
strongswan-a47486b5e4386b85c0a01424ba83930af8593ccc.tar.xz
prototype of dumm GUI
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in9
1 files changed, 8 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 30a9f282d..9751651c7 100644
--- a/configure.in
+++ b/configure.in
@@ -20,6 +20,7 @@ AC_INIT(strongSwan,4.2.2)
AM_INIT_AUTOMAKE(tar-ustar)
AC_C_BIGENDIAN
AC_SUBST(confdir, '${sysconfdir}')
+PKG_PROG_PKG_CONFIG
dnl =================================
dnl check --enable-xxx & --with-xxx
@@ -581,11 +582,17 @@ if test x$curl = xtrue; then
fi
if test x$xml = xtrue; then
- PKG_CHECK_MODULES(xml, [libxml-2.0],, AC_MSG_ERROR([No libxml2 package information found]))
+ PKG_CHECK_MODULES(xml, [libxml-2.0])
AC_SUBST(xml_CFLAGS)
AC_SUBST(xml_LIBS)
fi
+if test x$dumm = xtrue; then
+ PKG_CHECK_MODULES(gtk, [gtk+-2.0 vte])
+ AC_SUBST(gtk_CFLAGS)
+ AC_SUBST(gtk_LIBS)
+fi
+
if test x$fast = xtrue; then
AC_HAVE_LIBRARY([neo_cgi],[LIBS="$LIBS"],[AC_MSG_ERROR([ClearSilver library neo_cgi not found!])])
AC_HAVE_LIBRARY([neo_utl],[LIBS="$LIBS"],[AC_MSG_ERROR([ClearSilver library neo_utl not found!])])