aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2009-04-24 14:14:43 +0000
committerMartin Willi <martin@strongswan.org>2009-04-24 14:14:43 +0000
commitadc25ec252244de4d9fe9e729175af5a50b44d96 (patch)
tree5b936b1e5a89984604b78dbcd07eb96daa7127ee /configure.in
parent7f56b494616fca022b157eff393a0bfa19cf5e2b (diff)
downloadstrongswan-adc25ec252244de4d9fe9e729175af5a50b44d96.tar.bz2
strongswan-adc25ec252244de4d9fe9e729175af5a50b44d96.tar.xz
added missing configure.in changes for attr/resolv_conf plugins
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in28
1 files changed, 27 insertions, 1 deletions
diff --git a/configure.in b/configure.in
index 505b983d9..8763e0fee 100644
--- a/configure.in
+++ b/configure.in
@@ -47,7 +47,7 @@ AC_ARG_WITH(
)
AC_ARG_WITH(
[resolv-conf],
- AS_HELP_STRING([--with-resolv-conf=file],[set the file to store DNS server information other than "sysconfdir/resolv.conf"]),
+ AS_HELP_STRING([--with-resolv-conf=file],[set the file to use in DNS handler plugin other than "sysconfdir/resolv.conf"]),
[AC_SUBST(resolv_conf, "$withval")],
[AC_SUBST(resolv_conf, "${sysconfdir}/resolv.conf")]
)
@@ -638,6 +638,28 @@ AC_ARG_ENABLE(
)
AC_ARG_ENABLE(
+ [attr],
+ AS_HELP_STRING([--disable-attr],[disable strongswan.conf based configuration attribute plugin. (default is NO).]),
+ [if test x$enableval = xyes; then
+ attr=true
+ else
+ attr=false
+ fi],
+ attr=true
+)
+
+AC_ARG_ENABLE(
+ [resolv-conf],
+ AS_HELP_STRING([--disable-resolv-conf],[disable resolv.conf DNS handler plugin. (default is NO).]),
+ [if test x$enableval = xyes; then
+ resolvconf=true
+ else
+ resolvconf=false
+ fi],
+ resolvconf=true
+)
+
+AC_ARG_ENABLE(
[padlock],
AS_HELP_STRING([--enable-padlock],[enables VIA Padlock crypto plugin. (default is NO).]),
[if test x$enableval = xyes; then
@@ -962,6 +984,8 @@ AM_CONDITIONAL(USE_UCI, test x$uci = xtrue)
AM_CONDITIONAL(USE_SMP, test x$smp = xtrue)
AM_CONDITIONAL(USE_SQL, test x$sql = xtrue)
AM_CONDITIONAL(USE_UPDOWN, test x$updown = xtrue)
+AM_CONDITIONAL(USE_ATTR, test x$attr = xtrue)
+AM_CONDITIONAL(USE_RESOLV_CONF, test x$resolvconf = xtrue)
AM_CONDITIONAL(USE_UNIT_TESTS, test x$unittest = xtrue)
AM_CONDITIONAL(USE_LOAD_TESTS, test x$loadtest = xtrue)
AM_CONDITIONAL(USE_EAP_SIM, test x$eap_sim = xtrue)
@@ -1065,6 +1089,8 @@ AC_OUTPUT(
src/charon/plugins/uci/Makefile
src/charon/plugins/stroke/Makefile
src/charon/plugins/updown/Makefile
+ src/charon/plugins/attr/Makefile
+ src/charon/plugins/resolv_conf/Makefile
src/charon/plugins/unit_tester/Makefile
src/charon/plugins/load_tester/Makefile
src/stroke/Makefile