aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2009-04-24 05:32:17 +0200
committerTobias Brunner <tobias@strongswan.org>2009-04-24 05:32:17 +0200
commitbf45d6dd3ba921dc48c5ef402d1ca2f1575fc190 (patch)
tree4b0db14585ce757a8ef583b6fc9251ec1551486d /configure.in
parentbcbf110938cfb630bbf752b778e9be30e13eb735 (diff)
downloadstrongswan-bf45d6dd3ba921dc48c5ef402d1ca2f1575fc190.tar.bz2
strongswan-bf45d6dd3ba921dc48c5ef402d1ca2f1575fc190.tar.xz
added a configure option to enable the Vstr string library even if register_printf_function is available
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in18
1 files changed, 16 insertions, 2 deletions
diff --git a/configure.in b/configure.in
index 95635b740..ff858f186 100644
--- a/configure.in
+++ b/configure.in
@@ -712,6 +712,14 @@ AC_ARG_ENABLE(
fi]
)
+AC_ARG_ENABLE(
+ [vstr],
+ AS_HELP_STRING([--enable-vstr],[enforce using the Vstr string library to replace glibc-like printf hooks (default is NO).]),
+ [if test x$enableval = xyes; then
+ vstr=true
+ fi]
+)
+
dnl =========================
dnl set up compiler and flags
dnl =========================
@@ -844,8 +852,14 @@ AC_CHECK_FUNC(
[AC_DEFINE(HAVE_PRINTF_HOOKS)],
[
AC_MSG_NOTICE([printf does not support custom format specifiers!])
- AC_HAVE_LIBRARY([vstr],[LIBS="$LIBS"]; vstr=true,[AC_MSG_ERROR([Vstr string library not found])])
- ])
+ vstr=true
+ ]
+)
+
+if test x$vstr = xtrue; then
+ AC_HAVE_LIBRARY([vstr],[LIBS="$LIBS"],[AC_MSG_ERROR([Vstr string library not found])])
+ AC_DEFINE(USE_VSTR)
+fi
if test x$gmp = xtrue; then
AC_HAVE_LIBRARY([gmp],[LIBS="$LIBS"],[AC_MSG_ERROR([GNU Multi Precision library gmp not found])])