aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2010-02-22 14:56:35 +0100
committerMartin Willi <martin@revosec.ch>2010-02-26 11:44:32 +0100
commitdab05604978ee4bee8896d1763fbaef17f7dde83 (patch)
tree9b381e5ffebbe4cdb7d359b58f04e6903360eae3 /configure.in
parentc711687c00d1bdfdfeda47471f6447175f7e523d (diff)
downloadstrongswan-dab05604978ee4bee8896d1763fbaef17f7dde83.tar.bz2
strongswan-dab05604978ee4bee8896d1763fbaef17f7dde83.tar.xz
Moved socket and socket-raw implementations to plugins
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in14
1 files changed, 14 insertions, 0 deletions
diff --git a/configure.in b/configure.in
index e3eccd977..7c4895954 100644
--- a/configure.in
+++ b/configure.in
@@ -114,6 +114,8 @@ ARG_DISBL_SET([kernel-netlink], [disable the netlink kernel interface.])
ARG_ENABL_SET([kernel-pfkey], [enable the PF_KEY kernel interface.])
ARG_ENABL_SET([kernel-pfroute], [enable the PF_ROUTE kernel interface.])
ARG_ENABL_SET([kernel-klips], [enable the KLIPS kernel interface.])
+ARG_DISBL_SET([socket-default], [disable default socket implementation for charon.])
+ARG_ENABL_SET([socket-raw], [enable raw socket implementation of charon, enforced if pluto is enabled])
ARG_ENABL_SET([nat-transport], [enable NAT traversal with IPsec transport mode in pluto.])
ARG_DISBL_SET([vendor-id], [disable the sending of the strongSwan vendor ID in pluto.])
ARG_DISBL_SET([xauth-vid], [disable the sending of the XAUTH vendor ID.])
@@ -234,6 +236,14 @@ if test x$medcli = xtrue; then
mediation=true
fi
+if test x$pluto = xtrue; then
+ if test x$socket_raw = xfalse; then
+ AC_MSG_NOTICE([Enforcing --enable-socket-raw/--disable-socket-default, as pluto is enabled])
+ socket_default=false
+ socket_raw=true
+ fi
+fi
+
dnl ===========================================
dnl check required libraries and header files
dnl ===========================================
@@ -800,6 +810,8 @@ AM_CONDITIONAL(USE_KERNEL_NETLINK, test x$kernel_netlink = xtrue)
AM_CONDITIONAL(USE_KERNEL_PFKEY, test x$kernel_pfkey = xtrue)
AM_CONDITIONAL(USE_KERNEL_PFROUTE, test x$kernel_pfroute = xtrue)
AM_CONDITIONAL(USE_KERNEL_KLIPS, test x$kernel_klips = xtrue)
+AM_CONDITIONAL(USE_SOCKET_DEFAULT, test x$socket_default = xtrue)
+AM_CONDITIONAL(USE_SOCKET_RAW, test x$socket_raw = xtrue)
dnl other options
dnl =============
@@ -894,6 +906,8 @@ AC_OUTPUT(
src/charon/plugins/kernel_pfkey/Makefile
src/charon/plugins/kernel_pfroute/Makefile
src/charon/plugins/kernel_klips/Makefile
+ src/charon/plugins/socket_default/Makefile
+ src/charon/plugins/socket_raw/Makefile
src/charon/plugins/smp/Makefile
src/charon/plugins/sql/Makefile
src/charon/plugins/medsrv/Makefile