aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2006-05-17 14:21:38 +0000
committerMartin Willi <martin@strongswan.org>2006-05-17 14:21:38 +0000
commitdb26d00e73c9571010e52c2cd2b936d597401173 (patch)
treeaeab6530578bb35815ecc5d2882bcbb2a91abce3 /configure.in
parent6a0e76e50f0cae2e7a64a14a435fb7ded1545a05 (diff)
downloadstrongswan-db26d00e73c9571010e52c2cd2b936d597401173.tar.bz2
strongswan-db26d00e73c9571010e52c2cd2b936d597401173.tar.xz
- added random source ./configure options
- fixed default-pkcs11 option
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in48
1 files changed, 30 insertions, 18 deletions
diff --git a/configure.in b/configure.in
index 7536168e2..9a610f623 100644
--- a/configure.in
+++ b/configure.in
@@ -23,9 +23,31 @@ AC_SUBST(ipsecdir, '${libexecdir}/ipsec')
AC_SUBST(confdir, '${sysconfdir}')
AC_SUBST(piddir, '/var/run')
-dnl ===========================
-dnl check --enable-xxx params
-dnl ===========================
+dnl =================================
+dnl check --enable-xxx & --with-xxx
+dnl =================================
+
+
+AC_ARG_WITH(
+ [default-pkcs11],
+ AS_HELP_STRING([--with-default-pkcs11=lib],[set the default PKCS11 library other than /usr/lib/opensc-pkcs11.so]),
+ [AC_DEFINE_UNQUOTED(PKCS11_DEFAULT_LIB, "$withval")],
+ [AC_DEFINE_UNQUOTED(PKCS11_DEFAULT_LIB, "/usr/lib/opensc-pkcs11.so")]
+)
+
+AC_ARG_WITH(
+ [random-device],
+ AS_HELP_STRING([--with-random-device=dev],[set the device for real random data other than /dev/random]),
+ [AC_DEFINE_UNQUOTED(DEV_RANDOM, "$withval")],
+ [AC_DEFINE_UNQUOTED(DEV_RANDOM, "/dev/random")]
+)
+
+AC_ARG_WITH(
+ [urandom-device],
+ AS_HELP_STRING([--with-urandom-device=dev],[set the device for pseudo random data other than /dev/urandom]),
+ [AC_DEFINE_UNQUOTED(DEV_URANDOM, "$withval")],
+ [AC_DEFINE_UNQUOTED(DEV_URANDOM, "/dev/urandom")]
+)
AC_ARG_ENABLE(
[http],
@@ -37,27 +59,17 @@ AM_CONDITIONAL(USE_LIBCURL, test x$http = xtrue)
AC_ARG_ENABLE(
[ldap],
- AS_HELP_STRING([--enable-ldap],[enable fetching of CRLs from LDAP (default is NO). Requires openldap. \
- Protocol version 2 or 3 are supported, use --with-ldap=version to specify \
- explicitly.]),
+ AS_HELP_STRING([--enable-ldap],[enable fetching of CRLs from LDAP (default is NO). Requires openLDAP.]),
ldap=true
- [case "${enableval}" in
- 2) AC_DEFINE(LDAP_VER, 2) ;;
- 3) AC_DEFINE(LDAP_VER, 3) ;;
- *) AC_MSG_ERROR([Invalid LDAP protocol version specified!]) ;;
- esac
- ]
+ AC_DEFINE(LDAP_VER, 3)
)
AM_CONDITIONAL(USE_LDAP, test x$ldap = xtrue)
AC_ARG_ENABLE(
- [pkcs11],
- AS_HELP_STRING([--enable-pkcs11],[enable PKCS11 smartcard support (default is NO). \
- Set the default PKCS11 library using \
- --enable-pkcs11=/path/to/default-pkcs11.so]),
+ [smartcard],
+ AS_HELP_STRING([--enable-smartcard],[enable smartcard support (default is NO).]),
smartcard=true
AC_DEFINE(SMARTCARD)
- AC_DEFINE_UNQUOTED(PKCS11_DEFAULT_LIB, "$enableval")
)
AM_CONDITIONAL(USE_SMARTCARD, test x$smartcard = xtrue)
@@ -65,7 +77,7 @@ AC_ARG_ENABLE(
[leak-detective],
AS_HELP_STRING([--enable-leak-detective],[enable malloc hooks to find memory leaks (default is NO).]),
leak_detective=true
- AC_DEFINE(USE_LEAK_DETECTIVE)
+ AC_DEFINE(LEAK_DETECTIVE)
)
AM_CONDITIONAL(USE_LEAK_DETECTIVE, test x$leak_detective = xtrue)