aboutsummaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2010-03-08 12:40:45 +0100
committerMartin Willi <martin@revosec.ch>2010-03-08 13:16:12 +0100
commit40f130dab3c42c3d2b0ab6221a91f2effa1123ed (patch)
tree44c89d0b7c6bb71dea2746b7e086f0471c7a198e /configure.in
parent33e4ee59eddc40d4f19c428f2eb259a7e8deb282 (diff)
downloadstrongswan-40f130dab3c42c3d2b0ab6221a91f2effa1123ed.tar.bz2
strongswan-40f130dab3c42c3d2b0ab6221a91f2effa1123ed.tar.xz
Implemented the PRF_KEYED_SHA1 algorithm in the openssl plugin
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in11
1 files changed, 6 insertions, 5 deletions
diff --git a/configure.in b/configure.in
index 81249920f..89a32febb 100644
--- a/configure.in
+++ b/configure.in
@@ -208,7 +208,6 @@ fi
if test x$eap_aka = xtrue; then
fips_prf=true;
- sha1=true;
simaka=true;
fi
@@ -218,7 +217,9 @@ if test x$eap_sim = xtrue; then
fi
if test x$fips_prf = xtrue; then
- sha1=true;
+ if test x$openssl = xfalse; then
+ sha1=true;
+ fi
fi
if test x$smp = xtrue; then
@@ -676,9 +677,6 @@ if test x$md5 = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" md5"
pluto_plugins=${pluto_plugins}" md5"
fi
-if test x$fips_prf = xtrue; then
- libstrongswan_plugins=${libstrongswan_plugins}" fips-prf"
-fi
if test x$random = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" random"
pluto_plugins=${pluto_plugins}" random"
@@ -730,6 +728,9 @@ if test x$gcrypt = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" gcrypt"
pluto_plugins=${pluto_plugins}" gcrypt"
fi
+if test x$fips_prf = xtrue; then
+ libstrongswan_plugins=${libstrongswan_plugins}" fips-prf"
+fi
if test x$xcbc = xtrue; then
libstrongswan_plugins=${libstrongswan_plugins}" xcbc"
fi