aboutsummaryrefslogtreecommitdiffstats
path: root/src/charon/plugins/unit_tester/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2009-06-08 19:02:31 +0200
committerMartin Willi <martin@strongswan.org>2009-06-09 11:27:34 +0200
commit08874d6ae29745de264f269b15afbbf6cd5acaad (patch)
treeac0b24b305747b80849bb69c4ed6bc14c626843d /src/charon/plugins/unit_tester/Makefile.am
parent3240cab9782f78a5c18395763012808d0c532f44 (diff)
downloadstrongswan-08874d6ae29745de264f269b15afbbf6cd5acaad.tar.bz2
strongswan-08874d6ae29745de264f269b15afbbf6cd5acaad.tar.xz
implemented a speed test for public key algorithms
Diffstat (limited to 'src/charon/plugins/unit_tester/Makefile.am')
-rw-r--r--src/charon/plugins/unit_tester/Makefile.am3
1 files changed, 2 insertions, 1 deletions
diff --git a/src/charon/plugins/unit_tester/Makefile.am b/src/charon/plugins/unit_tester/Makefile.am
index af03e4e50..a1352a64e 100644
--- a/src/charon/plugins/unit_tester/Makefile.am
+++ b/src/charon/plugins/unit_tester/Makefile.am
@@ -1,7 +1,7 @@
INCLUDES = -I$(top_srcdir)/src/libstrongswan -I$(top_srcdir)/src/charon
-AM_CFLAGS = -rdynamic
+AM_CFLAGS = -rdynamic -lrt
plugin_LTLIBRARIES = libstrongswan-unit-tester.la
@@ -14,6 +14,7 @@ libstrongswan_unit_tester_la_SOURCES = unit_tester.c unit_tester.h tests.h \
tests/test_sqlite.c \
tests/test_mutex.c \
tests/test_rsa_gen.c \
+ tests/test_pubkey_speed.c \
tests/test_cert.c \
tests/test_med_db.c \
tests/test_aes.c \