aboutsummaryrefslogtreecommitdiffstats
path: root/src/libfreeswan/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2006-05-16 14:24:03 +0000
committerMartin Willi <martin@strongswan.org>2006-05-16 14:24:03 +0000
commitf2c2d395ff756505be10b9d3e8420af498f33cc2 (patch)
tree7202a334e20710bab1d0b3e848ecc964168ccf5f /src/libfreeswan/Makefile.am
parenteedfdfbe6e15ecc724eca705688472e8be73afec (diff)
downloadstrongswan-f2c2d395ff756505be10b9d3e8420af498f33cc2.tar.bz2
strongswan-f2c2d395ff756505be10b9d3e8420af498f33cc2.tar.xz
- introduced autotools
- first working version - make dist should work - things to do: - UML testing! - more cleanups
Diffstat (limited to 'src/libfreeswan/Makefile.am')
-rw-r--r--src/libfreeswan/Makefile.am20
1 files changed, 20 insertions, 0 deletions
diff --git a/src/libfreeswan/Makefile.am b/src/libfreeswan/Makefile.am
new file mode 100644
index 000000000..83f439574
--- /dev/null
+++ b/src/libfreeswan/Makefile.am
@@ -0,0 +1,20 @@
+noinst_LIBRARIES = libfreeswan.a
+libfreeswan_a_SOURCES = addrtoa.c addrtot.c addrtypeof.c anyaddr.c atoaddr.c atoasr.c \
+ atosa.c atosubnet.c atoul.c copyright.c datatot.c freeswan.h \
+ goodmask.c initaddr.c initsaid.c initsubnet.c internal.h ipcomp.h \
+ ipsec_ah.h ipsec_alg.h ipsec_encap.h ipsec_eroute.h ipsec_errs.h \
+ ipsec_esp.h ipsec_ipe4.h ipsec_kversion.h ipsec_life.h ipsec_md5h.h \
+ ipsec_param.h ipsec_policy.h ipsec_proto.h ipsec_radij.h ipsec_rcv.h \
+ ipsec_sa.h ipsec_sha1.h ipsec_stats.h ipsec_tunnel.h ipsec_xform.h \
+ ipsec_xmit.h keyblobtoid.c optionsfrom.c pfkey_v2_build.c pfkey_v2_debug.c \
+ pfkey_v2_ext_bits.c pfkey_v2_parse.c portof.c prng.c radij.h rangetoa.c \
+ pfkey.h pfkeyv2.h rangetosubnet.c sameaddr.c satoa.c \
+ satot.c subnetof.c subnettoa.c subnettot.c \
+ subnettypeof.c ttoaddr.c ttodata.c ttoprotoport.c ttosa.c ttosubnet.c ttoul.c \
+ ultoa.c ultot.c version.c
+INCLUDES = -I$(top_srcdir)/src/pluto
+AM_CFLAGS = -DNAT_TRAVERSAL
+dist_man3_MANS = anyaddr.3 atoaddr.3 atoasr.3 atosa.3 atoul.3 goodmask.3 initaddr.3 initsubnet.3 \
+ keyblobtoid.3 optionsfrom.3 portof.3 prng.3 rangetosubnet.3 sameaddr.3 subnetof.3 \
+ ttoaddr.3 ttodata.3 ttosa.3 ttoul.3 version.3
+