aboutsummaryrefslogtreecommitdiffstats
path: root/src/libhydra/Makefile.am
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2010-07-12 18:10:16 +0200
committerTobias Brunner <tobias@strongswan.org>2010-09-02 19:01:26 +0200
commit062a6022163f02ab9bea3dfac048bc1247d914f7 (patch)
tree4b119534f89ffbf100d1a3da033bd6dadfce4979 /src/libhydra/Makefile.am
parent08c0d340b8f0c05c4ee6ba9336cd56a432f84b7d (diff)
downloadstrongswan-062a6022163f02ab9bea3dfac048bc1247d914f7.tar.bz2
strongswan-062a6022163f02ab9bea3dfac048bc1247d914f7.tar.xz
Moved all kernel plugins to libhydra.
Diffstat (limited to 'src/libhydra/Makefile.am')
-rw-r--r--src/libhydra/Makefile.am28
1 files changed, 28 insertions, 0 deletions
diff --git a/src/libhydra/Makefile.am b/src/libhydra/Makefile.am
index 62ec8f4a2..ebaf79233 100644
--- a/src/libhydra/Makefile.am
+++ b/src/libhydra/Makefile.am
@@ -48,6 +48,34 @@ if MONOLITHIC
endif
endif
+if USE_KERNEL_PFKEY
+ SUBDIRS += plugins/kernel_pfkey
+if MONOLITHIC
+ libhydra_la_LIBADD += plugins/kernel_pfkey/libstrongswan-kernel-pfkey.la
+endif
+endif
+
+if USE_KERNEL_PFROUTE
+ SUBDIRS += plugins/kernel_pfroute
+if MONOLITHIC
+ libhydra_la_LIBADD += plugins/kernel_pfroute/libstrongswan-kernel-pfroute.la
+endif
+endif
+
+if USE_KERNEL_KLIPS
+ SUBDIRS += plugins/kernel_klips
+if MONOLITHIC
+ libhydra_la_LIBADD += plugins/kernel_klips/libstrongswan-kernel-klips.la
+endif
+endif
+
+if USE_KERNEL_NETLINK
+ SUBDIRS += plugins/kernel_netlink
+if MONOLITHIC
+ libhydra_la_LIBADD += plugins/kernel_netlink/libstrongswan-kernel-netlink.la
+endif
+endif
+
if USE_RESOLVE
SUBDIRS += plugins/resolve
if MONOLITHIC