aboutsummaryrefslogtreecommitdiffstats
path: root/src/libstrongswan/Makefile.am
diff options
context:
space:
mode:
authorAndreas Steffen <andreas.steffen@strongswan.org>2006-06-16 05:52:52 +0000
committerAndreas Steffen <andreas.steffen@strongswan.org>2006-06-16 05:52:52 +0000
commit307b4ded5e1e911c115974ee0a10992839692d20 (patch)
tree59dc979e86acb275f6caeeca28935e36fbafa701 /src/libstrongswan/Makefile.am
parent277379620c93ba7eb0c6c78927293f8e29249f52 (diff)
downloadstrongswan-307b4ded5e1e911c115974ee0a10992839692d20.tar.bz2
strongswan-307b4ded5e1e911c115974ee0a10992839692d20.tar.xz
added crl support
Diffstat (limited to 'src/libstrongswan/Makefile.am')
-rw-r--r--src/libstrongswan/Makefile.am43
1 files changed, 31 insertions, 12 deletions
diff --git a/src/libstrongswan/Makefile.am b/src/libstrongswan/Makefile.am
index 68e5497d2..5f495a5ad 100644
--- a/src/libstrongswan/Makefile.am
+++ b/src/libstrongswan/Makefile.am
@@ -1,19 +1,38 @@
lib_LTLIBRARIES = libstrongswan.la
libstrongswan_la_SOURCES = \
+definitions.c definitions.h \
+types.c types.h \
+library.c library.h \
asn1/oid.c asn1/oid.h \
-crypto/rsa/rsa_private_key.c crypto/rsa/rsa_public_key.h crypto/rsa/rsa_private_key.h crypto/rsa/rsa_public_key.c \
-crypto/prfs/hmac_prf.c crypto/prfs/hmac_prf.h crypto/prfs/prf.c crypto/prfs/prf.h crypto/signers/hmac_signer.c \
-crypto/signers/hmac_signer.h crypto/signers/signer.c crypto/signers/signer.h crypto/crypters/aes_cbc_crypter.c \
-crypto/crypters/crypter.c crypto/crypters/aes_cbc_crypter.h crypto/crypters/crypter.h crypto/hashers/sha1_hasher.c \
-crypto/hashers/md5_hasher.c crypto/hashers/hasher.h crypto/hashers/md5_hasher.h crypto/hashers/hasher.c \
-crypto/hashers/sha1_hasher.h crypto/diffie_hellman.c crypto/prf_plus.h crypto/x509.c crypto/prf_plus.c \
-crypto/hmac.c crypto/x509.h crypto/hmac.h crypto/diffie_hellman.h utils/identification.h utils/iterator.h \
-utils/linked_list.c utils/linked_list.h utils/tester.c utils/leak_detective.c utils/logger_manager.c \
-utils/randomizer.c utils/tester.h utils/leak_detective.h utils/host.c utils/logger_manager.h utils/randomizer.h \
-utils/logger.c utils/host.h utils/logger.h utils/identification.c utils/lexparser.c utils/lexparser.h \
-asn1/ttodata.c asn1/ttodata.h asn1/pem.c asn1/asn1.c asn1/pem.h asn1/asn1.h definitions.h types.h \
-definitions.c library.c types.c library.h
+asn1/asn1.c asn1/asn1.h \
+asn1/pem.c asn1/pem.h \
+asn1/ttodata.c asn1/ttodata.h \
+crypto/rsa/rsa_private_key.c crypto/rsa/rsa_private_key.h \
+crypto/rsa/rsa_public_key.h crypto/rsa/rsa_public_key.c \
+crypto/prfs/hmac_prf.c crypto/prfs/hmac_prf.h \
+crypto/prfs/prf.c crypto/prfs/prf.h \
+crypto/signers/hmac_signer.c crypto/signers/hmac_signer.h \
+crypto/signers/signer.c crypto/signers/signer.h \
+crypto/crypters/crypter.c crypto/crypters/crypter.h \
+crypto/crypters/aes_cbc_crypter.c crypto/crypters/aes_cbc_crypter.h\
+crypto/hashers/hasher.h crypto/hashers/hasher.c \
+crypto/hashers/sha1_hasher.c crypto/hashers/sha1_hasher.h \
+crypto/hashers/md5_hasher.c crypto/hashers/md5_hasher.h \
+crypto/prf_plus.h crypto/prf_plus.c \
+crypto/hmac.c crypto/hmac.h \
+crypto/x509.c crypto/x509.h \
+crypto/crl.c crypto/crl.h \
+crypto/diffie_hellman.c crypto/diffie_hellman.h \
+utils/identification.c utils/identification.h \
+utils/linked_list.c utils/linked_list.h utils/iterator.h\
+utils/randomizer.c utils/randomizer.h \
+utils/logger.c utils/logger.h \
+utils/logger_manager.c utils/logger_manager.h \
+utils/host.c utils/host.h \
+utils/lexparser.c utils/lexparser.h \
+utils/leak_detective.c utils/leak_detective.h \
+utils/tester.c utils/tester.h
libstrongswan_la_LIBADD = -lgmp -lpthread