aboutsummaryrefslogtreecommitdiffstats
path: root/src/libstrongswan/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2013-10-11 11:06:02 +0200
committerMartin Willi <martin@revosec.ch>2013-10-11 11:06:02 +0200
commitcabe5c0ff40f3a67d0d091d1bfdc2948b203737d (patch)
tree62df7243a5579a6e7e0c5987ecbaf6585b7e49f8 /src/libstrongswan/Makefile.am
parentebca34d782fef5fe9ff930301079f5e119983c9e (diff)
downloadstrongswan-cabe5c0ff40f3a67d0d091d1bfdc2948b203737d.tar.bz2
strongswan-cabe5c0ff40f3a67d0d091d1bfdc2948b203737d.tar.xz
printf-hook-builtin: Add a new "builtin" backend using its own printf() routines
Overloads printf C library functions by a self-contained implementation, based on klibc. Does not yet feature all the required default formatters, including those for floating point values.
Diffstat (limited to 'src/libstrongswan/Makefile.am')
-rw-r--r--src/libstrongswan/Makefile.am9
1 files changed, 8 insertions, 1 deletions
diff --git a/src/libstrongswan/Makefile.am b/src/libstrongswan/Makefile.am
index c0f8c39dc..54b19e139 100644
--- a/src/libstrongswan/Makefile.am
+++ b/src/libstrongswan/Makefile.am
@@ -79,7 +79,7 @@ threading/rwlock.h threading/rwlock_condvar.h threading/lock_profiler.h \
utils/utils.h utils/chunk.h utils/debug.h utils/enum.h utils/identification.h \
utils/lexparser.h utils/optionsfrom.h utils/capabilities.h utils/backtrace.h \
utils/leak_detective.h utils/printf_hook/printf_hook.h \
-utils/printf_hook/printf_hook_vstr.h \
+utils/printf_hook/printf_hook_vstr.h utils/printf_hook/printf_hook_builtin.h \
utils/settings.h utils/integrity_checker.h
endif
@@ -119,9 +119,16 @@ if USE_VSTR
libstrongswan_la_LIBADD += -lvstr
endif
+if USE_BUILTIN_PRINTF
+ libstrongswan_la_SOURCES += utils/printf_hook/printf_hook_builtin.c
+ libstrongswan_la_LIBADD += -lm
+endif
+
+if !USE_BUILTIN_PRINTF
if !USE_VSTR
libstrongswan_la_SOURCES += utils/printf_hook/printf_hook_glibc.c
endif
+endif
if USE_LIBCAP
libstrongswan_la_LIBADD += -lcap