aboutsummaryrefslogtreecommitdiffstats
path: root/src/libstrongswan/plugins/cmac/Makefile.am
diff options
context:
space:
mode:
authorTobias Brunner <tobias@strongswan.org>2012-04-03 10:40:47 +0200
committerTobias Brunner <tobias@strongswan.org>2012-04-03 10:40:47 +0200
commitc0d39c205cec5c9ede38c60d7c0b6deb11504eb5 (patch)
treec397ef2b5dd57ec06d00dea707a484cc3a79e669 /src/libstrongswan/plugins/cmac/Makefile.am
parent9a6b1cb412a37e0d206390cd0c22c24105580585 (diff)
downloadstrongswan-c0d39c205cec5c9ede38c60d7c0b6deb11504eb5.tar.bz2
strongswan-c0d39c205cec5c9ede38c60d7c0b6deb11504eb5.tar.xz
Implemented AES-CMAC based PRF and signer.
The cmac plugin implements AES-CMAC as defined in RFC 4493 and the signer and PRF based on it as defined in RFC 4494 and RFC 4615, respectively.
Diffstat (limited to 'src/libstrongswan/plugins/cmac/Makefile.am')
-rw-r--r--src/libstrongswan/plugins/cmac/Makefile.am16
1 files changed, 16 insertions, 0 deletions
diff --git a/src/libstrongswan/plugins/cmac/Makefile.am b/src/libstrongswan/plugins/cmac/Makefile.am
new file mode 100644
index 000000000..ce0104f11
--- /dev/null
+++ b/src/libstrongswan/plugins/cmac/Makefile.am
@@ -0,0 +1,16 @@
+
+INCLUDES = -I$(top_srcdir)/src/libstrongswan
+
+AM_CFLAGS = -rdynamic
+
+if MONOLITHIC
+noinst_LTLIBRARIES = libstrongswan-cmac.la
+else
+plugin_LTLIBRARIES = libstrongswan-cmac.la
+endif
+
+libstrongswan_cmac_la_SOURCES = \
+ cmac_plugin.h cmac_plugin.c cmac.h cmac.c \
+ cmac_prf.h cmac_prf.c cmac_signer.h cmac_signer.c
+
+libstrongswan_cmac_la_LDFLAGS = -module -avoid-version