aboutsummaryrefslogtreecommitdiffstats
path: root/src/libstrongswan/plugins/pgp/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@strongswan.org>2009-08-17 13:46:04 +0200
committerMartin Willi <martin@strongswan.org>2009-08-26 11:23:50 +0200
commit9493dd2ce0b0330cf8874cc5b474822f33eff6b7 (patch)
treeec1c688b0a12d02c39518428de1172f9a5c264a5 /src/libstrongswan/plugins/pgp/Makefile.am
parent4e3d1e804e834b961ca488407f24d6f4a39312cd (diff)
downloadstrongswan-9493dd2ce0b0330cf8874cc5b474822f33eff6b7.tar.bz2
strongswan-9493dd2ce0b0330cf8874cc5b474822f33eff6b7.tar.xz
implemented a pgp plugin providing PGP key parsing builders
Diffstat (limited to 'src/libstrongswan/plugins/pgp/Makefile.am')
-rw-r--r--src/libstrongswan/plugins/pgp/Makefile.am12
1 files changed, 12 insertions, 0 deletions
diff --git a/src/libstrongswan/plugins/pgp/Makefile.am b/src/libstrongswan/plugins/pgp/Makefile.am
new file mode 100644
index 000000000..c143e9e2d
--- /dev/null
+++ b/src/libstrongswan/plugins/pgp/Makefile.am
@@ -0,0 +1,12 @@
+
+INCLUDES = -I$(top_srcdir)/src/libstrongswan
+
+AM_CFLAGS = -rdynamic
+
+plugin_LTLIBRARIES = libstrongswan-pgp.la
+
+libstrongswan_pgp_la_SOURCES = pgp_plugin.h pgp_plugin.c \
+ pgp_builder.h pgp_builder.c
+
+libstrongswan_pgp_la_LDFLAGS = -module -avoid-version
+