aboutsummaryrefslogtreecommitdiffstats
path: root/src/pluto/Makefile.am
diff options
context:
space:
mode:
authorAndreas Steffen <andreas.steffen@strongswan.org>2009-04-18 14:50:31 +0000
committerAndreas Steffen <andreas.steffen@strongswan.org>2009-04-18 14:50:31 +0000
commita6e3ec13897a926c795794534f07c4fa2726b18f (patch)
treefcdc2a385f9fd9b5bea3a812eed6c88aab1beb5f /src/pluto/Makefile.am
parent815510e6372300604a8e6b3c5642c747248b8b66 (diff)
downloadstrongswan-a6e3ec13897a926c795794534f07c4fa2726b18f.tar.bz2
strongswan-a6e3ec13897a926c795794534f07c4fa2726b18f.tar.xz
created pluto and scepclient now use libstrongswan-lite
Diffstat (limited to 'src/pluto/Makefile.am')
-rw-r--r--src/pluto/Makefile.am38
1 files changed, 5 insertions, 33 deletions
diff --git a/src/pluto/Makefile.am b/src/pluto/Makefile.am
index 2194cda2b..c2126abad 100644
--- a/src/pluto/Makefile.am
+++ b/src/pluto/Makefile.am
@@ -90,49 +90,21 @@ AM_CFLAGS = \
-DPLUTO -DKLIPS -DDEBUG
pluto_LDADD = \
-oid.o debug.o linked_list.o enumerator.o settings.o utils.o chunk.o \
+$(LIBSTRONGSWANDIR)/libstrongswan-lite.la \
$(LIBFREESWANDIR)/libfreeswan.a \
$(LIBCRYPTODIR)/libcrypto.a \
-lgmp -lresolv -lpthread -ldl
-if USE_LEAK_DETECTIVE
- AM_CFLAGS += -DLEAK_DETECTIVE
- pluto_LDADD += backtrace.o leak_detective.o
-endif
-
_pluto_adns_LDADD = \
$(LIBFREESWANDIR)/libfreeswan.a \
-lresolv -ldl
dist_man_MANS = pluto.8 ipsec.secrets.5
-# Copy functions from libstrongswan
-oid.o : $(LIBSTRONGSWANDIR)/asn1/oid.c $(LIBSTRONGSWANDIR)/asn1/oid.h
- $(COMPILE) -c -o $@ $<
-
-debug.o : $(LIBSTRONGSWANDIR)/debug.c $(LIBSTRONGSWANDIR)/debug.h
- $(COMPILE) -c -o $@ $<
-
-backtrace.o : $(LIBSTRONGSWANDIR)/utils/backtrace.c $(LIBSTRONGSWANDIR)/utils/backtrace.h
- $(COMPILE) -c -o $@ $<
-
-leak_detective.o : $(LIBSTRONGSWANDIR)/utils/leak_detective.c $(LIBSTRONGSWANDIR)/utils/leak_detective.h
- $(COMPILE) -c -o $@ $<
-
-linked_list.o : $(LIBSTRONGSWANDIR)/utils/linked_list.c $(LIBSTRONGSWANDIR)/utils/linked_list.h
- $(COMPILE) -c -o $@ $<
-
-enumerator.o : $(LIBSTRONGSWANDIR)/utils/enumerator.c $(LIBSTRONGSWANDIR)/utils/enumerator.h
- $(COMPILE) -c -o $@ $<
-
-settings.o : $(LIBSTRONGSWANDIR)/settings.c $(LIBSTRONGSWANDIR)/settings.h
- $(COMPILE) -c -o $@ $<
-
-utils.o : $(LIBSTRONGSWANDIR)/utils.c $(LIBSTRONGSWANDIR)/utils.h
- $(COMPILE) -c -o $@ $<
-
-chunk.o : $(LIBSTRONGSWANDIR)/chunk.c $(LIBSTRONGSWANDIR)/chunk.h
- $(COMPILE) -c -o $@ $<
+# This compile option activates the memory leak detective
+if USE_LEAK_DETECTIVE
+ AM_CFLAGS += -DLEAK_DETECTIVE
+endif
# This compile option activates the sending of a strongSwan VID
if USE_VENDORID