aboutsummaryrefslogtreecommitdiffstats
path: root/src/stroke/Makefile.am
diff options
context:
space:
mode:
authorMartin Willi <martin@revosec.ch>2013-07-17 14:45:39 +0200
committerMartin Willi <martin@revosec.ch>2013-07-18 14:59:19 +0200
commit19cb07b89050c0e3ea6a11e1914318c4ff1284b5 (patch)
tree46313e34da73df7e8474c24122d97261f98b1d06 /src/stroke/Makefile.am
parentc577b5eb44bb6f515ebbb532b8c2f802968d7771 (diff)
downloadstrongswan-19cb07b89050c0e3ea6a11e1914318c4ff1284b5.tar.bz2
strongswan-19cb07b89050c0e3ea6a11e1914318c4ff1284b5.tar.xz
automake: replace INCLUDES by AM_CPPFLAGS
INCLUDES are now deprecated and throw warnings when using automake 1.13. We now also differentiate AM_CPPFLAGS and AM_CFLAGS, where includes and defines are passed to AM_CPPFLAGS only.
Diffstat (limited to 'src/stroke/Makefile.am')
-rw-r--r--src/stroke/Makefile.am5
1 files changed, 3 insertions, 2 deletions
diff --git a/src/stroke/Makefile.am b/src/stroke/Makefile.am
index 2d2d05748..ed170bd08 100644
--- a/src/stroke/Makefile.am
+++ b/src/stroke/Makefile.am
@@ -4,11 +4,12 @@ stroke_SOURCES = \
stroke.c stroke_msg.h stroke_keywords.c stroke_keywords.h
stroke_LDADD = $(top_builddir)/src/libstrongswan/libstrongswan.la $(SOCKLIB)
-INCLUDES = -I$(top_srcdir)/src/libstrongswan
EXTRA_DIST = stroke_keywords.txt Android.mk
BUILT_SOURCES = stroke_keywords.c
MAINTAINERCLEANFILES = stroke_keywords.c
-AM_CFLAGS = -DIPSEC_PIDDIR=\"${piddir}\"
+AM_CPPFLAGS = \
+ -I$(top_srcdir)/src/libstrongswan \
+ -DIPSEC_PIDDIR=\"${piddir}\"
stroke_keywords.c: $(srcdir)/stroke_keywords.txt $(srcdir)/stroke_keywords.h
$(AM_V_GEN) \