aboutsummaryrefslogtreecommitdiffstats
path: root/testing/Makefile.am
diff options
context:
space:
mode:
authorAndreas Steffen <andreas.steffen@strongswan.org>2007-08-28 06:40:39 +0000
committerAndreas Steffen <andreas.steffen@strongswan.org>2007-08-28 06:40:39 +0000
commit8234dd1216565311b07837889142b838d8a6fd93 (patch)
treea70e6fc3040511f5e34ba222ef529e4203f977b5 /testing/Makefile.am
parent35800a11eeabda3586b6cf87adcb04ef6278f657 (diff)
downloadstrongswan-8234dd1216565311b07837889142b838d8a6fd93.tar.bz2
strongswan-8234dd1216565311b07837889142b838d8a6fd93.tar.xz
testing/do-tests is made from do-tests.in by inserting actual routing table
Diffstat (limited to 'testing/Makefile.am')
-rw-r--r--testing/Makefile.am11
1 files changed, 11 insertions, 0 deletions
diff --git a/testing/Makefile.am b/testing/Makefile.am
new file mode 100644
index 000000000..2ce6f2cd0
--- /dev/null
+++ b/testing/Makefile.am
@@ -0,0 +1,11 @@
+noinst_SCRIPTS = do-tests
+CLEANFILES = do-tests
+EXTRA_DIST = do-tests.in make-testing start-testing stop-testing \
+ testing.conf hosts images scripts tests INSTALL README
+
+do-tests : do-tests.in
+ sed \
+ -e "s:\@IPSEC_ROUTING_TABLE\@:$(IPSEC_ROUTING_TABLE):" \
+ $< > $@
+ chmod +x $@
+