aboutsummaryrefslogtreecommitdiffstats
path: root/src/starter/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'src/starter/Makefile.am')
-rw-r--r--src/starter/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/src/starter/Makefile.am b/src/starter/Makefile.am
index f72d2edba..a0ce6ae61 100644
--- a/src/starter/Makefile.am
+++ b/src/starter/Makefile.am
@@ -6,7 +6,7 @@ keywords.c files.h keywords.h cmp.c starter.c cmp.h exec.c invokecharon.c \
exec.h invokecharon.h lex.yy.c loglite.c klips.c klips.h
INCLUDES = \
--I${linuxdir} \
+-I${linux_headers} \
-I$(top_srcdir)/src/libstrongswan \
-I$(top_srcdir)/src/libfreeswan \
-I$(top_srcdir)/src/pluto \
@@ -18,6 +18,8 @@ AM_CFLAGS = \
-DIPSEC_CONFDIR=\"${confdir}\" \
-DIPSEC_PIDDIR=\"${piddir}\" \
-DIPSEC_EAPDIR=\"${eapdir}\" \
+-DDEV_RANDOM=\"${random_device}\" \
+-DDEV_URANDOM=\"${urandom_device}\" \
-DDEBUG
starter_LDADD = defs.o $(top_builddir)/src/libfreeswan/libfreeswan.a $(top_builddir)/src/libstrongswan/libstrongswan.la $(SOCKLIB)