aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-04-22 10:21:44 -0300
committerprspkt <prspkt@protonmail.com>2019-04-23 20:41:43 +0300
commit01dbe7856721068d2ecd6af2659e0bd34787a371 (patch)
treeb77c9fe2d022b191fe50541cb669ad2662afb87c
parentaa03737b1caf52b97622e3c5de349677c236ab3a (diff)
downloadaports-01dbe7856721068d2ecd6af2659e0bd34787a371.tar.bz2
aports-01dbe7856721068d2ecd6af2659e0bd34787a371.tar.xz
testing/gotop: new aport
-rw-r--r--testing/gotop/APKBUILD35
1 files changed, 35 insertions, 0 deletions
diff --git a/testing/gotop/APKBUILD b/testing/gotop/APKBUILD
new file mode 100644
index 0000000000..f5c0718f72
--- /dev/null
+++ b/testing/gotop/APKBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Leo <thinkabit.ukim@gmail.com>
+pkgname=gotop
+pkgver=3.0.0
+pkgrel=0
+pkgdesc="Terminal based graphical activity monitor"
+url="https://github.com/cjbassi/gotop"
+arch="all"
+license="AGPL-3.0-or-later"
+depends="procps" # Remove once #138 on cjbassi/gotop is fixed
+makedepends="git go"
+source="$pkgname-$pkgver.tar.gz::https://github.com/cjbassi/gotop/archive/${pkgver}.tar.gz"
+builddir="$srcdir/src/github.com/cjbassi/gotop"
+
+prepare() {
+ default_prepare
+ mkdir -p "$srcdir"/src/github.com/cjbassi
+ mv "$srcdir"/$pkgname-$pkgver "$builddir"/
+}
+
+build() {
+ cd "$builddir"
+ GOPATH="$srcdir" go build -v -o bin/$pkgname .
+}
+
+check() {
+ cd "$builddir"
+ # No testsuite is provided
+ ./bin/$pkgname --help
+}
+
+package() {
+ cd "$builddir"
+ install -Dm755 bin/$pkgname "$pkgdir"/usr/bin/$pkgname
+}
+sha512sums="012cc627fa7013409f3775d5bf2528e25e275fc285fea7ae93a1afec33474c923cc6cd9accb24fce479ab229c98d6438cc9f5eb7dea37f72c1905516d5fdbf6e gotop-3.0.0.tar.gz"