aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-03-26 00:06:53 +0200
committerprspkt <prspkt@protonmail.com>2019-03-26 00:20:29 +0200
commit031a00b248d0e20f168f83e4cb9921ee744862fc (patch)
tree21903e1d54e6c9a045d2970a6f909c5abbec282e
parent3cd9ca2e879309bce9363696881102dc088b2859 (diff)
downloadaports-031a00b248d0e20f168f83e4cb9921ee744862fc.tar.bz2
aports-031a00b248d0e20f168f83e4cb9921ee744862fc.tar.xz
testing/py-pycountry: clarify license, modernize
-rw-r--r--testing/py-pycountry/APKBUILD29
1 files changed, 7 insertions, 22 deletions
diff --git a/testing/py-pycountry/APKBUILD b/testing/py-pycountry/APKBUILD
index 94e3260e90..29fb2a3c2e 100644
--- a/testing/py-pycountry/APKBUILD
+++ b/testing/py-pycountry/APKBUILD
@@ -5,37 +5,22 @@ _pkgname=pycountry
pkgver=1.4
pkgrel=0
pkgdesc="ISO country, subdivision, language, currency and script definitions and their translations"
-url="http://pypi.python.org/pypi/pycountry"
+url="https://pypi.org/project/pycountry"
arch="noarch"
-license="LGPL-2.0-or-later"
+license="LGPL-2.1-or-later"
depends=""
-depends_dev=""
makedepends="python2-dev py-lxml py-setuptools"
-install=""
-subpackages=""
source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip"
-
-_builddir="$srcdir"/$_pkgname-$pkgver
-prepare() {
- local i
- cd "$_builddir"
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$_pkgname-$pkgver
build() {
- cd "$_builddir"
- python2 setup.py build || return 1
+ cd "$builddir"
+ python2 setup.py build
}
package() {
- cd "$_builddir"
- python2 setup.py install --root=$pkgdir/ || return 1
+ cd "$builddir"
+ python2 setup.py install --prefix=/usr --root="$pkgdir"
}
-md5sums="72f18d648215ababf1b82246a4fbe9d8 pycountry-1.4.zip"
-sha256sums="c8e8dd244ad32bc1dbb55565b83f9277d0e0ad423c190844acd7e4b9831c3652 pycountry-1.4.zip"
sha512sums="59e6741f8c4a92412391ea672f6dc3778d87fcc38a5f37615bb60c8d022990425cdd8c04724c8eac1d503f11fea68a21989cd24fed060fe3efbdbeb7ef9177be pycountry-1.4.zip"