aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuca Weiss <luca@z3ntu.xyz>2020-04-13 17:43:23 +0200
committerAriadne Conill <ariadne@dereferenced.org>2020-04-13 21:45:40 +0000
commit03a1c4a5f1d68055801d45c2b4830cec96a727e4 (patch)
tree8589e82474d5f1b68d097429f1e5afc5ca3c9d63
parent448c868fe09961874ecb3ab70f09bfea116865e5 (diff)
downloadaports-03a1c4a5f1d68055801d45c2b4830cec96a727e4.tar.bz2
aports-03a1c4a5f1d68055801d45c2b4830cec96a727e4.tar.xz
main/font-bh-ttf: fix wrong fonts directory and modernize
fontutil.m4 from font-util-dev queries pkg-config (fontconfig.pc) for the correct font path, this failed before and an incorrect fallback was used. Fix this by including fontconfig-dev as makedepends.
-rw-r--r--main/font-bh-ttf/APKBUILD20
1 files changed, 7 insertions, 13 deletions
diff --git a/main/font-bh-ttf/APKBUILD b/main/font-bh-ttf/APKBUILD
index d4d906528e..60fc6c2556 100644
--- a/main/font-bh-ttf/APKBUILD
+++ b/main/font-bh-ttf/APKBUILD
@@ -1,42 +1,36 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=font-bh-ttf
pkgver=1.0.3
-pkgrel=0
+pkgrel=1
pkgdesc="X.org bh TTF fonts"
url="http://xorg.freedesktop.org/"
arch="all"
license="custom"
depends="encodings font-alias mkfontscale mkfontdir fontconfig"
-makedepends="font-util-dev bdftopcf"
-install=
+makedepends="font-util-dev bdftopcf fontconfig-dev"
source="https://www.x.org/releases/individual/font/$pkgname-$pkgver.tar.bz2"
-_builddir="$srcdir/$pkgname-$pkgver"
-
prepare() {
- cd "$_builddir"
- update_config_sub || return 1
+ default_prepare
+ update_config_sub
}
build() {
- cd "$_builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
--prefix=/usr \
--with-mapfiles=/usr/share/fonts/util \
- --with-fontdir=/usr/share/fonts/TTF \
- || return 1
- make || return 1
+ --with-fontdir=/usr/share/fonts/TTF
+ make
}
package() {
- cd "$_builddir"
make -j1 DESTDIR="$pkgdir" \
MKFONTDIR=: \
MKFONTSCALE=: \
FCCACHE=: \
- install || return 1
+ install
}
sha512sums="36b5b6bbc2894cd90a372e8131281a462b42d503be3e9af8565edbcd954b336690aa86a0b6fb162d865ba71b65669c5b911658c5b820effcea39d086d485be25 font-bh-ttf-1.0.3.tar.bz2"