aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarc Vertes <marc.vertes@ugrid.net>2016-04-14 09:45:47 +0200
committerNatanael Copa <ncopa@alpinelinux.org>2016-04-18 09:19:17 +0000
commit03c30e9f2d41929f69d865a946d1a705edfe067d (patch)
tree5538c0870b8cd4b05815242e30f58593f6c85648
parent0430dcb47cc9093cc680714a042a9fd5a3073bf0 (diff)
downloadaports-03c30e9f2d41929f69d865a946d1a705edfe067d.tar.bz2
aports-03c30e9f2d41929f69d865a946d1a705edfe067d.tar.xz
testing/mongodb: use wiredtiger from system instead of internal
This requires wiretiger-2.8.0. Previous 2.7.0 was causing problems when dropping collections which are now fixed in 2.8.0.
-rw-r--r--testing/mongodb/APKBUILD5
1 files changed, 3 insertions, 2 deletions
diff --git a/testing/mongodb/APKBUILD b/testing/mongodb/APKBUILD
index 39e03b92d9..236b975992 100644
--- a/testing/mongodb/APKBUILD
+++ b/testing/mongodb/APKBUILD
@@ -2,14 +2,14 @@
# Contributor: Marc Vertes <marc.vertes@ugrid.net>
pkgname=mongodb
pkgver=3.2.4
-pkgrel=1
+pkgrel=2
pkgdesc='A high-performance, open source, schema-free document-oriented database'
url='http://www.mongodb.org'
arch='x86_64'
license='AGPL3'
pkgusers="mongodb"
depends=
-depends_dev="scons openssl-dev pcre-dev snappy-dev boost-dev asio-dev libpcap-dev"
+depends_dev="scons openssl-dev pcre-dev snappy-dev boost-dev asio-dev libpcap-dev wiredtiger-dev"
makedepends="$depends_dev"
install="$pkgname.pre-install"
source="http://downloads.mongodb.org/src/mongodb-src-r${pkgver}.tar.gz
@@ -48,6 +48,7 @@ _buildopts="
--disable-warnings-as-errors \
--use-system-boost \
--use-system-pcre \
+ --use-system-wiredtiger \
--use-system-snappy \
--use-system-zlib \
"