aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2019-12-25 12:06:09 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-25 12:40:03 +0100
commit04842fcba8d027d4a37848b23700a1f383117a74 (patch)
tree6e01fda8eed77ef0c6232a6337b1a9afdf34041a
parentab120e1e95cec8bd38a04fc2710a365dde63af6b (diff)
downloadaports-04842fcba8d027d4a37848b23700a1f383117a74.tar.bz2
aports-04842fcba8d027d4a37848b23700a1f383117a74.tar.xz
community/kmousetool: move from testing
-rw-r--r--community/kmousetool/APKBUILD (renamed from testing/kmousetool/APKBUILD)13
1 files changed, 11 insertions, 2 deletions
diff --git a/testing/kmousetool/APKBUILD b/community/kmousetool/APKBUILD
index 166442f684..bbc2107f1c 100644
--- a/testing/kmousetool/APKBUILD
+++ b/community/kmousetool/APKBUILD
@@ -8,11 +8,18 @@ url="https://kde.org/applications/utilities/org.kde.kmousetool"
pkgdesc="A program that clicks the mouse for you"
license="GPL-2.0-or-later AND GFDL-1.2-only"
makedepends="extra-cmake-modules qt5-qtbase-dev kdbusaddons-dev kdoctools-dev ki18n-dev kiconthemes-dev knotifications-dev kxmlgui-dev phonon-dev libxt-dev libxtst-dev"
-source="https://download.kde.org/stable/release-service/$pkgver/src/$pkgname-$pkgver.tar.xz"
+source="https://download.kde.org/stable/release-service/$pkgver/src/kmousetool-$pkgver.tar.xz"
subpackages="$pkgname-doc $pkgname-lang"
+prepare() {
+ default_prepare
+
+ mkdir "$builddir"/build
+}
+
build() {
- cmake \
+ cd "$builddir"/build
+ cmake "$builddir" \
-DCMAKE_BUILD_TYPE=RelWithDebInfo \
-DCMAKE_INSTALL_PREFIX=/usr \
-DCMAKE_INSTALL_LIBDIR=lib
@@ -20,10 +27,12 @@ build() {
}
check() {
+ cd "$builddir"/build
CTEST_OUTPUT_ON_FAILURE=TRUE ctest
}
package() {
+ cd "$builddir"/build
DESTDIR="$pkgdir" make install
}