aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-04-08 15:29:07 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-04-09 22:56:42 -0300
commit052a1e22daef37ec4873e98650b9c2d6e55f7275 (patch)
tree1cca71f43fc5470678e0363f0c99fdf94f72bde6
parent220faeaa22d941085211d64ec55cc1fa6adb9b47 (diff)
downloadaports-052a1e22daef37ec4873e98650b9c2d6e55f7275.tar.bz2
aports-052a1e22daef37ec4873e98650b9c2d6e55f7275.tar.xz
main/cryptsetup1: remove
superseeded by cryptsetup 2.x
-rw-r--r--main/cryptsetup1/APKBUILD55
-rw-r--r--main/cryptsetup1/flush-stdout.patch17
-rw-r--r--main/cryptsetup1/libressl-2.7.patch13
3 files changed, 0 insertions, 85 deletions
diff --git a/main/cryptsetup1/APKBUILD b/main/cryptsetup1/APKBUILD
deleted file mode 100644
index db66d3d00c..0000000000
--- a/main/cryptsetup1/APKBUILD
+++ /dev/null
@@ -1,55 +0,0 @@
-# Contributor: Sören Tempel <soeren+alpine@soeren-tempel.net>
-# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
-pkgname=cryptsetup1
-pkgver=1.7.5
-pkgrel=4
-pkgdesc="Userspace setup tool for transparent encryption of block devices using the Linux 2.6 cryptoapi"
-url="https://gitlab.com/cryptsetup/cryptsetup"
-arch="all"
-license="GPL-2.0-or-later"
-depends=""
-conflicts="cryptsetup"
-replaces="cryptsetup"
-makedepends_build=""
-makedepends_host="lvm2-dev openssl-dev popt-dev util-linux-dev"
-makedepends="$makedepends_build $makedepends_host"
-subpackages="$pkgname-dev $pkgname-doc $pkgname-libs"
-source="https://www.kernel.org/pub/linux/utils/cryptsetup/v${pkgver%.*}/cryptsetup-$pkgver.tar.gz
- flush-stdout.patch
- libressl-2.7.patch
- "
-builddir="$srcdir"/cryptsetup-$pkgver
-
-build() {
- cd "$builddir"
- ./configure \
- --build=$CBUILD \
- --host=$CHOST \
- --prefix=/usr \
- --libdir=/lib \
- --sbindir=/sbin \
- --disable-static \
- --with-crypto_backend=openssl
- make
-}
-
-package() {
- cd "$builddir"
- make DESTDIR=$pkgdir install
-
- mkdir -p "$pkgdir"/usr/lib
- mv "$pkgdir"/lib/pkgconfig "$pkgdir"/usr/lib/
-
- mkdir -p "$pkgdir"/usr/share/doc/$pkgname/
- install -m644 README TODO FAQ "$pkgdir"/usr/share/doc/$pkgname/
-}
-
-libs() {
- pkgdesc="Cryptsetup shared library"
- mkdir -p "$subpkgdir"
- mv "$pkgdir"/lib "$subpkgdir"/
-}
-
-sha512sums="be4cf2815390f415edc3e1013222c9fe735b83c37278484e680cf7e0f6bdb850242bf057020d4c0d9f0e66106dbbc5b57abe34b351c99951d4aebb809e3c0473 cryptsetup-1.7.5.tar.gz
-301e3e3da5a899e0a6f01f44fbf37bb6a3f5b6a4fb41243bae6d3b7aea747276e784626cd1b19721cc264652c10ae8c560c4d20094e33bb82fb2fae0160682c0 flush-stdout.patch
-04686ed9407c69a68f608a1d8fb1e49e99476eea9adab789a3d78578ec01d352337529165abd5615416b1173ef0357dd35f977f8335ecb2f5610b8be998b7314 libressl-2.7.patch"
diff --git a/main/cryptsetup1/flush-stdout.patch b/main/cryptsetup1/flush-stdout.patch
deleted file mode 100644
index ae21a235f5..0000000000
--- a/main/cryptsetup1/flush-stdout.patch
+++ /dev/null
@@ -1,17 +0,0 @@
---- ./src/utils_tools.c.orig 2014-10-24 12:58:35.151717616 -0200
-+++ ./src/utils_tools.c 2014-10-24 13:00:42.716855265 -0200
-@@ -105,10 +105,13 @@
-
- case CRYPT_LOG_NORMAL:
- fputs(msg, stdout);
-+ fflush(stdout);
- break;
- case CRYPT_LOG_VERBOSE:
-- if (opt_verbose)
-+ if (opt_verbose) {
- fputs(msg, stdout);
-+ fflush(stdout);
-+ }
- break;
- case CRYPT_LOG_ERROR:
- fputs(msg, stderr);
diff --git a/main/cryptsetup1/libressl-2.7.patch b/main/cryptsetup1/libressl-2.7.patch
deleted file mode 100644
index 1d88c51a12..0000000000
--- a/main/cryptsetup1/libressl-2.7.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/lib/crypto_backend/crypto_openssl.c b/lib/crypto_backend/crypto_openssl.c
-index 21aee76..b0a6aeb 100644
---- a/lib/crypto_backend/crypto_openssl.c
-+++ b/lib/crypto_backend/crypto_openssl.c
-@@ -52,7 +52,7 @@ struct crypt_hmac {
- /*
- * Compatible wrappers for OpenSSL < 1.1.0
- */
--#if OPENSSL_VERSION_NUMBER < 0x10100000L || defined(LIBRESSL_VERSION_NUMBER)
-+#if OPENSSL_VERSION_NUMBER < 0x10100000L
- static void openssl_backend_init(void)
- {
- OpenSSL_add_all_algorithms();