aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-07-03 07:38:09 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-07-03 07:38:09 -0300
commit073e579ec6274589aabc5fdf26a756654b64a222 (patch)
treed60974ff81b6cb434fc0c82bb927b6ad248e3e5e
parent63e28717af76e39c963e6555c58e1f13dabe6105 (diff)
downloadaports-073e579ec6274589aabc5fdf26a756654b64a222.tar.bz2
aports-073e579ec6274589aabc5fdf26a756654b64a222.tar.xz
testing/perl-sys-syscall: fix url fix license
-rw-r--r--testing/perl-sys-syscall/APKBUILD17
1 files changed, 4 insertions, 13 deletions
diff --git a/testing/perl-sys-syscall/APKBUILD b/testing/perl-sys-syscall/APKBUILD
index cbe166cbbe..7f637b406b 100644
--- a/testing/perl-sys-syscall/APKBUILD
+++ b/testing/perl-sys-syscall/APKBUILD
@@ -4,17 +4,12 @@
pkgname=perl-sys-syscall
_pkgreal=Sys-Syscall
pkgver=0.25
-pkgrel=3
+pkgrel=4
pkgdesc="Invoke system calls that are otherwise difficult to do from Perl"
-url="http://search.cpan.org/dist/Sys-Syscall/"
+url="https://metacpan.org/release/Sys-Syscall"
arch="all !aarch64 !s390x"
-license="GPL PerlArtistic"
-cpandepends=""
-cpanmakedepends=""
-cpancheckdepends=""
-depends="$cpandepends"
-makedepends="perl-dev $cpanmakedepends"
-checkdepends="$cpancheckdepends"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
+makedepends="perl-dev"
subpackages="$pkgname-doc"
source="http://search.cpan.org/CPAN/authors/id/B/BR/BRADFITZ/$_pkgreal-$pkgver.tar.gz
ppc64le_epoll.patch
@@ -24,25 +19,21 @@ builddir="$srcdir/$_pkgreal-$pkgver"
prepare() {
default_prepare
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
}
build() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make
}
package() {
- cd "$builddir"
make DESTDIR="$pkgdir" install
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
check() {
- cd "$builddir"
export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}