aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFrancesco Colista <fcolista@alpinelinux.org>2019-03-25 07:58:22 +0000
committerFrancesco Colista <fcolista@alpinelinux.org>2019-03-25 07:58:27 +0000
commit08f172b2453e5c6a8ca00fe66dae8d1a2f01aca1 (patch)
treec3b2bbfd6198f76cefe647d0142f36075dfb391d
parenta3b771375b1e8f1496a674b0626793dac23c4eb6 (diff)
downloadaports-08f172b2453e5c6a8ca00fe66dae8d1a2f01aca1.tar.bz2
aports-08f172b2453e5c6a8ca00fe66dae8d1a2f01aca1.tar.xz
community/keybinder3: updated APKBUILD, added check()
-rw-r--r--community/keybinder3/APKBUILD16
1 files changed, 13 insertions, 3 deletions
diff --git a/community/keybinder3/APKBUILD b/community/keybinder3/APKBUILD
index 894854ba02..65a7982e0f 100644
--- a/community/keybinder3/APKBUILD
+++ b/community/keybinder3/APKBUILD
@@ -3,7 +3,7 @@
pkgname=keybinder3
_pkgname=keybinder-3.0
pkgver=0.3.2
-pkgrel=0
+pkgrel=1
pkgdesc="Library for registering global key bindings, for gtk-based applications. GTK3 version"
url="https://github.com/engla/keybinder"
arch="all"
@@ -15,9 +15,14 @@ subpackages="$pkgname-dev $pkgname-doc"
source="https://github.com/engla/keybinder/archive/$_pkgname-v${pkgver}.tar.gz"
builddir="$srcdir/keybinder-${_pkgname}-v$pkgver"
-build() {
+prepare() {
+ default_prepare
cd "$builddir"
./autogen.sh
+}
+
+build() {
+ cd "$builddir"
./configure \
--build=$CBUILD \
--host=$CHOST \
@@ -25,7 +30,12 @@ build() {
--enable-shared \
--disable-static \
--enable-gtk-doc
- make || return 1
+ make
+}
+
+check() {
+ cd "$builddir"
+ make check
}
package() {