aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-12-12 00:09:25 +0100
committerLeo <thinkabit.ukim@gmail.com>2019-12-12 00:16:53 +0100
commit094f4d1fc059104f212354edc72741534a9f3d18 (patch)
tree73147ea3139ae8a8d82df6afb6a35caf0fb35ecc
parente9c1c11ec636b8209f124efbf9cd2d72e4b8784f (diff)
downloadaports-094f4d1fc059104f212354edc72741534a9f3d18.tar.bz2
aports-094f4d1fc059104f212354edc72741534a9f3d18.tar.xz
main/perl-datetime-format-natural: upgrade to 1.08
-rw-r--r--main/perl-datetime-format-natural/APKBUILD14
1 files changed, 7 insertions, 7 deletions
diff --git a/main/perl-datetime-format-natural/APKBUILD b/main/perl-datetime-format-natural/APKBUILD
index 39a784c11d..4019cea412 100644
--- a/main/perl-datetime-format-natural/APKBUILD
+++ b/main/perl-datetime-format-natural/APKBUILD
@@ -3,12 +3,12 @@
# Maintainer: Leonardo Arena <rnalrd@alpinelinux.org>
pkgname=perl-datetime-format-natural
_pkgreal=DateTime-Format-Natural
-pkgver=1.07
+pkgver=1.08
pkgrel=0
pkgdesc="Create machine readable date/time with natural parsing logic"
-url="http://search.cpan.org/dist/DateTime-Format-Natural/"
+url="https://metacpan.org/release/DateTime-Format-Natural"
arch="noarch"
-license="GPL PerlArtistic"
+license="GPL-1.0-or-later OR Artistic-1.0-Perl"
cpandepends="perl-datetime-timezone perl-clone perl-params-validate
perl-list-moreutils perl-datetime perl-boolean"
cpanmakedepends="perl-module-util perl-test-mocktime perl-date-calc
@@ -16,20 +16,20 @@ cpanmakedepends="perl-module-util perl-test-mocktime perl-date-calc
depends="$cpandepends"
makedepends="perl-dev $cpanmakedepends"
subpackages="$pkgname-doc"
-source="http://search.cpan.org/CPAN/authors/id/S/SC/SCHUBIGER/$_pkgreal-$pkgver.tar.gz"
+source="https://cpan.metacpan.org/authors/id/S/SC/SCHUBIGER/DateTime-Format-Natural-$pkgver.tar.gz"
builddir="$srcdir/$_pkgreal-$pkgver"
build() {
cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
make
}
check() {
cd "$builddir"
- export CFLAGS=`perl -MConfig -E 'say $Config{ccflags}'`
+ export CFLAGS=$(perl -MConfig -E 'say $Config{ccflags}')
make test
}
@@ -39,4 +39,4 @@ package() {
find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
}
-sha512sums="f355c1c30fd70f5530e395624466068f6efb0dd69825fb34e660a9317766e2c2a67b3d8b2e39d68562c58be9fe9a78cb737bd21485023935e7bcaec57c4d23e8 DateTime-Format-Natural-1.07.tar.gz"
+sha512sums="92ce61df98bb4d15b41597a99d0c19972c2f1f24352c5af365d41afc13efde79f9e5fb23551208450e8fc0ee499f1a7cd6aa8ccd44f16991f3fccf48e8a6c635 DateTime-Format-Natural-1.08.tar.gz"