aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorNatanael Copa <ncopa@alpinelinux.org>2011-05-31 16:59:50 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2011-05-31 16:59:50 +0000
commit0a0cd0179422c614a92ef59475d00814a8f30a90 (patch)
tree54178b552f19f636cb0314d026a85585a13cc417
parentacb990eaeba685c72596152de35bf5a2e262c3ad (diff)
downloadaports-0a0cd0179422c614a92ef59475d00814a8f30a90.tar.bz2
aports-0a0cd0179422c614a92ef59475d00814a8f30a90.tar.xz
testing/perl-encode-locale: new aport
Encode::Locale perl module http://search.cpan.org/dist/Encode-Locale/
-rw-r--r--testing/perl-encode-locale/APKBUILD39
1 files changed, 39 insertions, 0 deletions
diff --git a/testing/perl-encode-locale/APKBUILD b/testing/perl-encode-locale/APKBUILD
new file mode 100644
index 0000000000..cab9fe58f7
--- /dev/null
+++ b/testing/perl-encode-locale/APKBUILD
@@ -0,0 +1,39 @@
+# Contributor: Natanael Copa <ncopa@alpinelinux.org>
+# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
+pkgname=perl-encode-locale
+pkgver=1.02
+pkgrel=0
+pkgdesc="Encode::Locale perl module"
+url="http://search.cpan.org/dist/Encode-Locale/"
+arch="noarch"
+license="GPLv2 or Artistic"
+depends="perl"
+makedepends="perl-dev"
+install=""
+subpackages="$pkgname-doc"
+source="http://search.cpan.org/CPAN/authors/id/G/GA/GAAS/Encode-Locale-$pkgver.tar.gz"
+
+_builddir="$srcdir"/Encode-Locale-$pkgver
+prepare() {
+ local i
+ cd "$_builddir"
+ for i in $source; do
+ case $i in
+ *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
+ esac
+ done
+}
+
+build() {
+ cd "$_builddir"
+ PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor || return 1
+ make && make test || return 1
+}
+
+package() {
+ cd "$_builddir"
+ make DESTDIR="$pkgdir" install || return 1
+ find "$pkgdir" \( -name perllocal.pod -o -name .packlist \) -delete
+}
+
+md5sums="96a950ee9b57e47e2b990b4c5dd7bf6e Encode-Locale-1.02.tar.gz"