aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-06-05 03:12:24 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-06-12 16:33:24 -0300
commit0a1b3713e05b0cf4e17df7f1e2bef396099d751f (patch)
tree1033651d5ae96d3aa9dbc359845fd28269f3b19a
parentb2aaa90db4397bf1e7a350642ed74d32adfe768d (diff)
downloadaports-0a1b3713e05b0cf4e17df7f1e2bef396099d751f.tar.bz2
aports-0a1b3713e05b0cf4e17df7f1e2bef396099d751f.tar.xz
community/anytun: modernize, fix license, fix url
-rw-r--r--community/anytun/APKBUILD33
-rw-r--r--community/anytun/fix-iostream.patch4
-rw-r--r--community/anytun/fix-werror-compile-flags.patch4
3 files changed, 14 insertions, 27 deletions
diff --git a/community/anytun/APKBUILD b/community/anytun/APKBUILD
index f7a2ece842..0bb2d84145 100644
--- a/community/anytun/APKBUILD
+++ b/community/anytun/APKBUILD
@@ -2,45 +2,32 @@
# Maintainer: Francesco Colista <fcolista@alpinelinux.org>
pkgname=anytun
pkgver=0.3.7
-pkgrel=1
+pkgrel=2
pkgdesc="Secure anycast tunneling protocol implementation for flexible and fault-tolerant VPNs"
-url="http://www.anytun.org"
+options="!check" # No testsuite
+url="https://www.anytun.org/"
arch="all"
-license="GPL-3.0"
-depends=""
+license="GPL-3.0-or-later"
depends_dev="openssl-dev boost-dev linux-headers"
makedepends="$depends_dev"
-install=""
-subpackages="$pkgname-dev $pkgname-doc"
+subpackages="$pkgname-dev $pkgname-doc $pkgname-openrc"
source="http://www.anytun.org/download/$pkgname-$pkgver.tar.gz
fix-werror-compile-flags.patch
fix-iostream.patch
$pkgname.initd"
-_builddir="$srcdir"/$pkgname-$pkgver/src
-prepare() {
- local i
- cd "$_builddir"
- cd ..
- for i in $source; do
- case $i in
- *.patch) msg $i; patch -p1 -i "$srcdir"/$i || return 1;;
- esac
- done
-}
+builddir="$srcdir"/$pkgname-$pkgver/src
build() {
- cd "$_builddir"
./configure \
--prefix=/usr \
--sysconfdir=/etc \
--use-ssl-crypto \
- --examplesdir=/usr/share/docs || return 1
- make || return 1
+ --examplesdir=/usr/share/docs
+ make
}
package() {
- cd "$_builddir"
mkdir -p ${pkgdir}/var/run/anytun ${pkgdir}/var/run/anytun-controld &>/dev/null
make install DESTDIR="${pkgdir}"
rm "${pkgdir}"/etc/init.d/$pkgname
@@ -48,6 +35,6 @@ package() {
}
sha512sums="bf1cccfd39b5190d7190590346be867de75ac7256d16648887b3988bdc01dccc4e5084cdad57990b753a55c12417a3c34f66a8871da035d79846aecc188e4578 anytun-0.3.7.tar.gz
-e2f23ed7183f7636716946458b108a7055beb190a89d462d815d164f61a5c52b268620f053e5bb169c48d4e9cd56ad2f1d3d65a23a202375ef13998c29f4fdf6 fix-werror-compile-flags.patch
-4d1115733f8d3d467bdd6348df451dfb60bff45685406792514717d27a567e323f76b12b4406a6d784f20716c08b596d6c09842c60e81c67fdaf8b0eed9b7530 fix-iostream.patch
+25c870750e2358afbf40d9fffb5d53aed84b8d763dd78fe698a124e362cd3d3eb6a850b59cb3bb50b0dbd51dd86944198d4a18b5c8a799561f53e76797e2c1e9 fix-werror-compile-flags.patch
+8c2eece0357666867f8cd9c7ef9307bcf88b9172ac033c18bd33ba470b3c19ad722c7eeafcda3a9ae95539d86ab04285fe5d7fa9766630f689c58e2c3fb239c3 fix-iostream.patch
a31455058e0ac60ed9457c79eea789ce19ba49abc200b59c0d8390eb0c3b6f09813177f9b679fb8ac69ac7b0be862e4604d19298ae4cd79925511fff3963e93d anytun.initd"
diff --git a/community/anytun/fix-iostream.patch b/community/anytun/fix-iostream.patch
index 12dffd8d6d..bc3e2e4a4c 100644
--- a/community/anytun/fix-iostream.patch
+++ b/community/anytun/fix-iostream.patch
@@ -1,5 +1,5 @@
---- a/src/routingTreeNode.cpp.orig 2018-03-27 19:30:45.345569478 +0300
-+++ b/src/routingTreeNode.cpp 2018-03-27 19:30:53.217662424 +0300
+--- a/routingTreeNode.cpp.orig 2018-03-27 19:30:45.345569478 +0300
++++ b/routingTreeNode.cpp 2018-03-27 19:30:53.217662424 +0300
@@ -44,6 +44,7 @@
*/
diff --git a/community/anytun/fix-werror-compile-flags.patch b/community/anytun/fix-werror-compile-flags.patch
index 5720a7d115..907499b466 100644
--- a/community/anytun/fix-werror-compile-flags.patch
+++ b/community/anytun/fix-werror-compile-flags.patch
@@ -1,7 +1,7 @@
diff --git a/src/configure b/src/configure
index 65a0c74..357628e 100755
---- a/src/configure
-+++ b/src/configure
+--- a/configure
++++ b/configure
@@ -217,8 +217,8 @@ if [ -n "$ERRORS" ] && [ $EBUILD_COMPAT -ne 1 ]; then
fi