aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJ0WI <J0WI@users.noreply.github.com>2019-06-09 20:06:00 +0200
committerLeo <thinkabit.ukim@gmail.com>2019-07-06 07:05:08 -0300
commit1085e17f7b3d7a1f9f14fead2ad0e5c4cb866174 (patch)
tree980a0a779f9312b6121bfaef36373686d2f28c20
parent80d1bbc9cd7bf5ff3f6819465cf25b9a0324babc (diff)
downloadaports-1085e17f7b3d7a1f9f14fead2ad0e5c4cb866174.tar.bz2
aports-1085e17f7b3d7a1f9f14fead2ad0e5c4cb866174.tar.xz
testing/cdist: upgrade to 5.1.1
-rw-r--r--testing/cdist/APKBUILD21
1 files changed, 11 insertions, 10 deletions
diff --git a/testing/cdist/APKBUILD b/testing/cdist/APKBUILD
index bc5c07e849..b6b9118062 100644
--- a/testing/cdist/APKBUILD
+++ b/testing/cdist/APKBUILD
@@ -1,20 +1,21 @@
# Contributor: Lucas Ramage <ramage.lucas@protonmail.com>
# Maintainer: Lucas Ramage <ramage.lucas@protonmail.com>
pkgname=cdist
-pkgver=4.10.4
-pkgrel=1
+pkgver=5.1.1
+pkgrel=0
pkgdesc="A Usable Configuration Management System"
arch="noarch"
-url="https://www.nico.schottelius.org/software/cdist/"
+url="https://www.cdi.st/"
options="!check"
-license="GPL-3.0"
+license="GPL-3.0-or-later"
depends="python3"
-source="https://github.com/ungleich/${pkgname}/releases/download/4.10.4/${pkgname}-${pkgver}.tar.gz"
+source="$pkgname-$pkgver.tar.gz::https://code.ungleich.ch/ungleich-public/$pkgname/uploads/5463b2c362325a54888f65ee774a0c9a/${pkgname}-${pkgver}.tar.gz"
package() {
- ./bin/${pkgname} 2> /dev/null
- python3 setup.py build install --root="${pkgdir}"
- find "$pkgdir" -type d -exec chmod 0755 {} \;
- find "$pkgdir" -type f -exec chmod a+r {} \;
+ ./bin/${pkgname} 2> /dev/null
+ python3 setup.py build install --root="${pkgdir}"
+ find "$pkgdir" -type d -exec chmod 0755 {} \;
+ find "$pkgdir" -type f -exec chmod a+r {} \;
}
-sha512sums="19b6bd824352d77f331a2bb1bec83066fb328550249068c8037e47e9e51aba743d96119cffd5fcdefb99d1f69444fb7c608a563dfcbccfc3f2e2700fee103636 cdist-4.10.4.tar.gz"
+
+sha512sums="3a51ac87331b8ada03dc762f002801b00a1d407519d5571c54342f50dabf375305d7f367a08fbab3b9b6cc7ab1e11da638a8505534cfc9b09694f9a15ed4e724 cdist-5.1.1.tar.gz"