aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2020-03-02 12:49:16 -0300
committerLeo <thinkabit.ukim@gmail.com>2020-03-02 13:59:38 -0300
commit1304e439351d3afe28ca4ba28a270e822a28f14a (patch)
tree8e024f97b6c8905b3b2a420dc3cb788d5fb05217
parenta0763f7040e1a4e8f8899f17aab89b58980fddee (diff)
downloadaports-1304e439351d3afe28ca4ba28a270e822a28f14a.tar.bz2
aports-1304e439351d3afe28ca4ba28a270e822a28f14a.tar.xz
community/quazip: modernize
-rw-r--r--community/quazip/APKBUILD12
1 files changed, 5 insertions, 7 deletions
diff --git a/community/quazip/APKBUILD b/community/quazip/APKBUILD
index 727ed5ea3e..09b6c49720 100644
--- a/community/quazip/APKBUILD
+++ b/community/quazip/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=quazip
pkgver=0.8.1
-pkgrel=0
+pkgrel=1
pkgdesc="C++ wrapper for the Gilles Vollant's ZIP/UNZIP C package"
options="!check" # Testsuite only available with qmake not cmake
url="https://sourceforge.net/projects/quazip/"
@@ -18,14 +18,12 @@ source="quazip-$pkgver.tar.gz::https://github.com/stachenov/quazip/archive/v$pkg
replaces="quazip-qt5"
build() {
- mkdir -p build
- cd build
- cmake \
+ cmake -B build . \
+ -DCMAKE_BUILD_TYPE=None \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_WITH_QT4:BOOL=OFF \
- -DCMAKE_CXX_FLAGS="$CFLAGS -fPIC" \
- ..
- make
+ -DCMAKE_CXX_FLAGS="$CFLAGS -fPIC"
+ make -C build
}
package() {