aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2017-12-19 14:46:11 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2017-12-29 19:27:11 +0000
commit14f680b47663fbb40686accdefd7aab5843a005c (patch)
tree77d5b0db59d21e6a8ac39da79494a265aa6d611d
parent46e135c71ac53d8708a6f5df8f9a413570af5038 (diff)
downloadaports-14f680b47663fbb40686accdefd7aab5843a005c.tar.bz2
aports-14f680b47663fbb40686accdefd7aab5843a005c.tar.xz
testing/py-core-api: new aport
-rw-r--r--testing/py-core-api/APKBUILD59
1 files changed, 59 insertions, 0 deletions
diff --git a/testing/py-core-api/APKBUILD b/testing/py-core-api/APKBUILD
new file mode 100644
index 0000000000..ad36e56836
--- /dev/null
+++ b/testing/py-core-api/APKBUILD
@@ -0,0 +1,59 @@
+# Contributor: Leonardo Arena <rnalrd@alpinelinux.org>
+# Maintainer:
+pkgname=py-core-api
+_pkgname=python-client
+pkgver=2.3.3
+pkgrel=0
+pkgdesc="Python client library for Core API"
+url="https://github.com/core-api/python-client"
+arch="noarch"
+license="Custom"
+depends="py-coreschema py-itypes py-requests"
+makedepends="python2-dev python3-dev py-setuptools py3-setuptools
+ py-uritemplate"
+checkdepends="py-flake8 py-coverage pytest py-jinja2 py-pycodestyle
+ py-pyflakes py-enum34"
+options="!check" #currently requires pyflakes-1.5.0
+subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
+source="$pkgname-$pkgver.tar.gz::https://github.com/core-api/python-client/archive/$pkgver.tar.gz"
+builddir="$srcdir"/$_pkgname-$pkgver
+
+build() {
+ cd "$builddir"
+ python2 setup.py --quiet build
+ python3 setup.py --quiet build
+}
+
+package() {
+ cd "$builddir"
+ mkdir -p "$pkgdir"/usr/bin
+}
+
+check() {
+ cd "$builddir"
+ python2 runtests
+ python3 runtests
+}
+
+_py2() {
+ depends="${depends//py-/py3-} py2-uritemplate.py"
+ _py python2
+}
+
+_py3() {
+ depends="${depends//py-/py3-} py3-uritemplate.py"
+ _py python3
+}
+
+_py() {
+ local python="$1"
+ local pyver="${1:6:1}"
+ pkgdesc="$pkgdesc (for $python)"
+ depends="$depends $python"
+ install_if="$pkgname=$pkgver-r$pkgrel $python"
+
+ cd "$builddir"
+ $python setup.py --quiet install --prefix=/usr --root="$subpkgdir"
+}
+
+sha512sums="aeae3ace84c0ce61552236b83db28e47492f5ac17a0e216e1a8eeddaf67270b94127f7a40f8a37cc5051abe097555adfd690a7e6c8801524ca77c916bd451ab8 py-core-api-2.3.3.tar.gz"