aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-09-07 22:49:12 -0300
committerLeo <thinkabit.ukim@gmail.com>2019-09-07 23:02:26 -0300
commit152fb9ecbe6b84668139f0d9974cb21b92ec592e (patch)
tree1f684455287744a78e003f62f85daf5ea5ff0cf4
parent16c495dee9026ae6b962ad0f15ea1c36621eacd8 (diff)
downloadaports-152fb9ecbe6b84668139f0d9974cb21b92ec592e.tar.bz2
aports-152fb9ecbe6b84668139f0d9974cb21b92ec592e.tar.xz
testing/py3-usb: drop py2
-rw-r--r--testing/py3-usb/APKBUILD50
1 files changed, 16 insertions, 34 deletions
diff --git a/testing/py3-usb/APKBUILD b/testing/py3-usb/APKBUILD
index 77231c6b2f..f83d128316 100644
--- a/testing/py3-usb/APKBUILD
+++ b/testing/py3-usb/APKBUILD
@@ -1,49 +1,31 @@
# Maintainer: Marian Buschsieweke <marian.buschsieweke@ovgu.de>
-pkgname=py-usb
+pkgname=py3-usb
_pkgname=pyusb
pkgver=1.0.2
-pkgrel=1
-pkgdesc="PyUSB offers easy USB devices communication in Python"
-url="https://pypi.python.org/pypi/pyusb"
+pkgrel=2
+pkgdesc="PyUSB offers easy USB devices communication in Python3"
+url="https://github.com/pyusb/pyusb"
arch="noarch"
license="BSD-3-Clause"
-makedepends="python2-dev python3-dev py-setuptools"
-subpackages="py2-${pkgname#py-}:_py2 py3-${pkgname#py-}:_py3"
-source="https://files.pythonhosted.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.tar.gz"
+depends="python3"
+makedepends="py3-setuptools"
+source="$pkgname-$pkgver.tar.gz::https://github.com/pyusb/pyusb/archive/v$pkgver.tar.gz"
builddir="$srcdir"/$_pkgname-$pkgver
+replaces="py-usb" # Backwards compatibility
+provides="py-usb=$pkgver-r$pkgrel" # Backwards compatibility
+
build() {
- cd "$builddir"
- python2 setup.py build
python3 setup.py build
}
-package() {
- mkdir -p "$pkgdir"
-}
-
-_py2() {
- replaces="$pkgname"
- _py python2
-}
-
-_py3() {
- _py python3
-}
-
-_py() {
- local python="$1"
- pkgdesc="$pkgdesc (for $python)"
- depends="$depends $python"
- install_if="$pkgname=$pkgver-r$pkgrel $python"
-
- cd "$builddir"
- $python setup.py install --prefix=/usr --root="$subpkgdir"
+check() {
+ cd tests
+ python3 testall.py
}
-check() {
- cd "$builddir"
- python3 setup.py test
+package() {
+ python3 setup.py install --prefix=/usr --root="$pkgdir"
}
-sha512sums="218d118c8572ed548d2317725a9717c0a442eb67c05148ccd90505a407bd8821a1519f511abc14f96b8e09d914f5a35f57cfabd57c47cb9b3fcd8b61947375a2 pyusb-1.0.2.tar.gz"
+sha512sums="6a264b796e17612004196a7a526a7c6df99feac9062f8354540221016411a78a65d413731aea2fc1206ed5ea2b84787078898b9ca3754164f1dfe2a9878b75a5 py3-usb-1.0.2.tar.gz"