aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorinfo@mobile-stream.com <info@mobile-stream.com>2018-11-28 07:01:20 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2018-11-30 12:54:12 +0000
commit176cd41390663c0d842059b80e90dc3ef11e52e9 (patch)
tree9b6e4638adf491bd049bb258b0577c4d40883e99
parentf068acfb28c773361e7353e0a0d64cc3b8772a9f (diff)
downloadaports-176cd41390663c0d842059b80e90dc3ef11e52e9.tar.bz2
aports-176cd41390663c0d842059b80e90dc3ef11e52e9.tar.xz
community/gammu: fix build
Compilation fails in libgammu/device/devfunc.c:socket_read() with a bunch of select()-related errors (probably due to some change in the include chain since the last rebuild). Fix by including <sys/select.h> explicitly. Test still passes on x86_64 and mipsel at least.
-rw-r--r--community/gammu/APKBUILD6
-rw-r--r--community/gammu/include-sys-select-h.patch10
2 files changed, 14 insertions, 2 deletions
diff --git a/community/gammu/APKBUILD b/community/gammu/APKBUILD
index bdc96a1a09..df41458520 100644
--- a/community/gammu/APKBUILD
+++ b/community/gammu/APKBUILD
@@ -3,7 +3,7 @@
# Maintainer: ScrumpyJack <scrumpyjack@st.ilet.to>
pkgname=gammu
pkgver=1.39.0
-pkgrel=1
+pkgrel=2
pkgdesc="Gammu provides an abstraction layer for cell phones access"
url="https://wammu.eu/"
arch="all"
@@ -14,6 +14,7 @@ makedepends="unixodbc-dev libdbi-dev postgresql-dev
subpackages="$pkgname-smsd:_smsd $pkgname-doc $pkgname-dev $pkgname-libs"
source="https://dl.cihar.com/$pkgname/releases/${pkgname}-${pkgver}.tar.bz2
disable-at-charset-test.patch
+ include-sys-select-h.patch
"
builddir="$srcdir/$pkgname-$pkgver"
@@ -48,4 +49,5 @@ _smsd() {
}
sha512sums="ed8994f6ec25d8ddbed23680e8a02db05c8e7f85aa6b8c0d409b5e8377e7c9e07fc61e62d80f6741d648709fb58a10ec631155d8b1ffc1c7d3b6e425cf53c797 gammu-1.39.0.tar.bz2
-3963da83e7bf9138f676242d0b7fe8ce3c8da7fe34d7ac12b6d439c48d2754e55c2b5442b7773f58fdcf16aa23872c58426fbb079cecc59ba143055cda543fa4 disable-at-charset-test.patch"
+3963da83e7bf9138f676242d0b7fe8ce3c8da7fe34d7ac12b6d439c48d2754e55c2b5442b7773f58fdcf16aa23872c58426fbb079cecc59ba143055cda543fa4 disable-at-charset-test.patch
+bcdbfa620dff24a01033bb670ec4dabae4c691224693d21105c6ca3cd30022b5825ad0669fd6325553b084d90bbde164113b08de7d102c7401d84076b9a59083 include-sys-select-h.patch"
diff --git a/community/gammu/include-sys-select-h.patch b/community/gammu/include-sys-select-h.patch
new file mode 100644
index 0000000000..a7d04feee3
--- /dev/null
+++ b/community/gammu/include-sys-select-h.patch
@@ -0,0 +1,10 @@
+--- a/libgammu/device/devfunc.c
++++ b/libgammu/device/devfunc.c
+@@ -22,6 +22,7 @@
+ # include <errno.h>
+ # include <ctype.h>
+ # include <signal.h>
++# include <sys/select.h>
+ # include <sys/socket.h>
+ # include <sys/stat.h>
+ #endif