aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBreno Leitao <breno.leitao@gmail.com>2017-05-08 19:44:22 +0000
committerBreno Leitao <breno.leitao@gmail.com>2017-05-08 19:46:35 +0000
commit1780a0dfdf57871c83f7104703ace40a1833675b (patch)
treec06b18e644d0498a9dd2dcc2074f140ee95914f9
parent7635e82b0a56e10ff90402cbc4fae0e25c505fe7 (diff)
downloadaports-1780a0dfdf57871c83f7104703ace40a1833675b.tar.bz2
aports-1780a0dfdf57871c83f7104703ace40a1833675b.tar.xz
testing/td-agent-bit: Fix build on ppc64le
There was a regression td-agent-bit that broke a function on ppc64le. This patch fixes it. This patch was also sent uptream, as: https://github.com/fluent/fluent-bit/pull/253
-rw-r--r--testing/td-agent-bit/0001-lib-flb_libco-Fix-ppc64-function-arguments.patch48
-rw-r--r--testing/td-agent-bit/APKBUILD4
2 files changed, 51 insertions, 1 deletions
diff --git a/testing/td-agent-bit/0001-lib-flb_libco-Fix-ppc64-function-arguments.patch b/testing/td-agent-bit/0001-lib-flb_libco-Fix-ppc64-function-arguments.patch
new file mode 100644
index 0000000000..fd0578a054
--- /dev/null
+++ b/testing/td-agent-bit/0001-lib-flb_libco-Fix-ppc64-function-arguments.patch
@@ -0,0 +1,48 @@
+From a0dfda11ab576da7b3c931f7512fa77b86d95209 Mon Sep 17 00:00:00 2001
+From: Breno Leitao <breno.leitao@gmail.com>
+Date: Mon, 8 May 2017 19:36:43 +0000
+Subject: [PATCH] lib: flb_libco: Fix ppc64 function arguments
+
+This software currently does not built on Power due to duplicated
+function.
+
+ lib/flb_libco/ppc.c:282:12: error: conflicting types for 'co_create'
+ cothread_t co_create(unsigned int size, void (*entry_)(void)) {
+
+ lib/flb_libco/libco.h:19:12: note: previous declaration of 'co_create' was here
+ cothread_t co_create(unsigned int, void (*)(void), size_t *);
+
+This is happening because commit
+b2bb2227cd2712df1946c438ec733b5956e9ecd8 forgot to change the function
+name on ppc source code.
+
+Signed-off-by: Breno Leitao <breno.leitao@gmail.com>
+---
+ lib/flb_libco/ppc.c | 4 +++-
+ 1 file changed, 3 insertions(+), 1 deletion(-)
+
+diff --git a/lib/flb_libco/ppc.c b/lib/flb_libco/ppc.c
+index e6536d56..8b70ad77 100755
+--- a/lib/flb_libco/ppc.c
++++ b/lib/flb_libco/ppc.c
+@@ -279,7 +279,8 @@ static uint32_t* co_create_(unsigned size, uintptr_t entry) {
+ return t;
+ }
+
+-cothread_t co_create(unsigned int size, void (*entry_)(void)) {
++cothread_t co_create(unsigned int size, void (*entry_)(void),
++ size_t *out_size) {
+ uintptr_t entry = (uintptr_t)entry_;
+ uint32_t* t = 0;
+
+@@ -289,6 +290,7 @@ cothread_t co_create(unsigned int size, void (*entry_)(void)) {
+ t = co_create_(size, entry);
+ }
+
++ *out_size = size;
+ if(t) {
+ uintptr_t sp;
+ int shift;
+--
+2.12.2
+
diff --git a/testing/td-agent-bit/APKBUILD b/testing/td-agent-bit/APKBUILD
index 85d2744997..d0914bd5c4 100644
--- a/testing/td-agent-bit/APKBUILD
+++ b/testing/td-agent-bit/APKBUILD
@@ -14,6 +14,7 @@ source="http://fluentbit.io/releases/0.10/$_pkgname-$pkgver.tar.gz
$pkgname.confd
$pkgname.initd
disable-jemalloc.patch
+ 0001-lib-flb_libco-Fix-ppc64-function-arguments.patch
"
builddir="$srcdir/"$_pkgname-$pkgver
@@ -47,4 +48,5 @@ package() {
sha512sums="93b1e6c277ebecb65e40d078d98f1942dcda7fa02abd1f8c2d95e4c73d20ec36bee0d0d072b7624894a5b75a455d5c25b91a08c6a05e391b40a03a63a15e3096 fluent-bit-0.10.1.tar.gz
6c1c67ac965fb9f54e362a7de8864afbffb9a22bffb5b5ca3a68f3950b9a27ccaee29d4bfb223035ccf5276e3fe09d0873685c58c47e055ad4bea57ccf80d90e td-agent-bit.confd
5103ab108bf0bafec2ca34db6e3a629977cd0a6ffb3f213b3885af5e2c08218ede4784d64310d6acdc7a09a9bc1e29330eaf692dbebdc6619de5a69cb1f80948 td-agent-bit.initd
-bf41aa1eef5ae0239acb2f54356d090d71611eb021de5b0d92be10079ef3bc5c7cc1dade1de98fd60354b883e53652a6f3f54a7a03acd00471e1f65d654aac32 disable-jemalloc.patch"
+bf41aa1eef5ae0239acb2f54356d090d71611eb021de5b0d92be10079ef3bc5c7cc1dade1de98fd60354b883e53652a6f3f54a7a03acd00471e1f65d654aac32 disable-jemalloc.patch
+cf78d431e23c9c14d1564b6c4f6bc6d1645a2d3a74a276eb1a0a50f9d1725b04cb83f368337293f2493b9940459fa3ee7c59bbd2b2f3f67faeb4c5ac20787ddb 0001-lib-flb_libco-Fix-ppc64-function-arguments.patch"