aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorprspkt <prspkt@protonmail.com>2019-04-03 22:15:29 +0300
committerprspkt <prspkt@protonmail.com>2019-04-03 22:30:31 +0300
commit1907497dd7dd55d09617c2e6b686a798cd97d272 (patch)
tree84039d48821e543ab61feb7064aeab2e9a6df237
parentf64942ac4631b74ca49dc469607635a2bd83bb2c (diff)
downloadaports-1907497dd7dd55d09617c2e6b686a798cd97d272.tar.bz2
aports-1907497dd7dd55d09617c2e6b686a798cd97d272.tar.xz
community/py-service_identity: set dependencies as common
-rw-r--r--community/py-service_identity/APKBUILD8
1 files changed, 4 insertions, 4 deletions
diff --git a/community/py-service_identity/APKBUILD b/community/py-service_identity/APKBUILD
index 34d595a160..c5b70624f3 100644
--- a/community/py-service_identity/APKBUILD
+++ b/community/py-service_identity/APKBUILD
@@ -8,7 +8,7 @@ pkgdesc="Service Identity Verification for pyOpenSSL"
url="https://service-identity.readthedocs.org/"
arch="noarch"
license="MIT"
-depends="py-attrs py-cryptography"
+depends="py-asn1 py-asn1-modules py-attrs py-characteristic py-cryptography"
makedepends="python2-dev py-setuptools py2-pytest python3-dev py3-pytest"
install=""
subpackages="py3-${pkgname/py-/}:_py3 py2-${pkgname/py-/}:_py2"
@@ -35,14 +35,14 @@ _py() {
}
_py2() {
- _py python2
- depends="py2-asn1 py2-asn1-modules py2-characteristic py2-ipaddress"
replaces="$pkgname"
+ depends="${depends//py-/py2-} py2-ipaddress"
+ _py python2
}
_py3() {
+ depends="${depends//py-/py3-}"
_py python3
- depends="py3-asn1 py3-asn1-modules py3-characteristic"
}
sha512sums="c1556e385035a8d43fd0e3960c0396b9d2536c5e3c7450b3669c8c9b8ff60b6a9d2f0282dc30c1fb46034b4abcb0ff6d74ed79f6bcc33f59035988ccaf3324d2 service_identity-18.1.0.tar.gz"