aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKevin Daudt <ops@ikke.info>2018-09-12 17:46:26 +0000
committerNatanael Copa <ncopa@alpinelinux.org>2018-09-27 06:15:09 +0000
commit1a8a04634245f476ec6239633a403f09a22f44e6 (patch)
treed7c6617a909af6693bcace097a41b0149308aa1b
parent2647441409bc9d6445aaa6e3371f3d395c58d62a (diff)
downloadaports-1a8a04634245f476ec6239633a403f09a22f44e6.tar.bz2
aports-1a8a04634245f476ec6239633a403f09a22f44e6.tar.xz
testing/foolsm: new aport
-rw-r--r--testing/foolsm/APKBUILD28
-rw-r--r--testing/foolsm/fix-non-standard-macro.patch13
2 files changed, 41 insertions, 0 deletions
diff --git a/testing/foolsm/APKBUILD b/testing/foolsm/APKBUILD
new file mode 100644
index 0000000000..3cf6a71131
--- /dev/null
+++ b/testing/foolsm/APKBUILD
@@ -0,0 +1,28 @@
+# Contributor: Kevin Daudt <kdaudt@alpinelinux.org>
+# Maintainer: Kevin Daudt <kdaudt@alpinelinux.org>
+pkgname=foolsm
+pkgver=1.0.10
+pkgrel=0
+pkgdesc="Link Status Monitor"
+url="https://lsm.foobar.fi/"
+arch="all"
+license="GPL-2.0-only"
+makedepends="linux-headers"
+options="!check" # No test suite availbe
+subpackages="$pkgname-doc"
+source="https://lsm.foobar.fi/download/foolsm-$pkgver.tar.gz
+ fix-non-standard-macro.patch"
+builddir="$srcdir/$pkgname-$pkgver"
+
+build() {
+ cd "$builddir"
+ make
+}
+
+package() {
+ cd "$builddir"
+ make install DESTDIR="$pkgdir" PREFIX=/usr
+}
+
+sha512sums="7437306cb2188446b31e23f01876a64aff7556797012b0cc83db57e328d71f2813d2f3771b2c6d22300fe0e5ba2eca3992d59c33c3984a7bcfe6a52d7b719657 foolsm-1.0.10.tar.gz
+4a0c851b2ae534c365adcc5798b56fc91b1efe7d4bcad90df411e93d7a4a0c620d3e9efa26504de877059c481de207c58c468ea577025db2933fa111f5620077 fix-non-standard-macro.patch"
diff --git a/testing/foolsm/fix-non-standard-macro.patch b/testing/foolsm/fix-non-standard-macro.patch
new file mode 100644
index 0000000000..58d87e2755
--- /dev/null
+++ b/testing/foolsm/fix-non-standard-macro.patch
@@ -0,0 +1,13 @@
+diff --git a/forkexec.c b/forkexec.c.new
+index 203d1d3202..e3708bbfa5 100644
+--- a/forkexec.c
++++ b/forkexec.c.new
+@@ -108,7 +108,7 @@ static void sigchld_hdl(int sig)
+ int script_status;
+ pid_t pid;
+
+- while ((pid = waitpid(WAIT_ANY, &script_status, WNOHANG)) != 0) {
++ while ((pid = waitpid(-1, &script_status, WNOHANG)) != 0) {
+ if(pid == -1) {
+ if(cfg.debug >= 9 && errno != ECHILD)
+ syslog(LOG_ERR, "%s: %s: %d: waitpid failed %s", __FILE__, __FUNCTION__, __LINE__, strerror(errno));