aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorBart Ribbers <bribbers@disroot.org>2020-01-13 13:56:37 +0100
committerRasmus Thomsen <oss@cogitri.dev>2020-01-13 14:35:31 +0100
commit1f54ed613615715e5c988487244d7a3f1e787467 (patch)
tree643ea3459ed98b5f4eea31ddfb49d5cae1d82833
parentaf1f17774317c6e15d1ae274e1b14ba1a3fdc3dd (diff)
downloadaports-1f54ed613615715e5c988487244d7a3f1e787467.tar.bz2
aports-1f54ed613615715e5c988487244d7a3f1e787467.tar.xz
community/plasma-desktop: fix broken activities KCM
As recommended by KDE, revert 567f71714faac305947573e307f486a9960cf1d1
-rw-r--r--community/plasma-desktop/APKBUILD8
-rw-r--r--community/plasma-desktop/revert-fix-jagginess-for-activities-list-icons.patch33
2 files changed, 38 insertions, 3 deletions
diff --git a/community/plasma-desktop/APKBUILD b/community/plasma-desktop/APKBUILD
index 5c32ab9a26..a8e90cf5f7 100644
--- a/community/plasma-desktop/APKBUILD
+++ b/community/plasma-desktop/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Bart Ribbers <bribbers@disroot.org>
pkgname=plasma-desktop
pkgver=5.17.5
-pkgrel=0
+pkgrel=1
pkgdesc="KDE Plasma Desktop"
arch="all !armhf" # armhf blocked by qt5-qtdeclarative
url='https://www.kde.org/workspaces/plasmadesktop/'
@@ -47,7 +47,8 @@ depends_dev="
"
makedepends="$depends_dev extra-cmake-modules kdoctools-dev"
checkdepends="xvfb-run iso-codes"
-source="https://download.kde.org/stable/plasma/$pkgver/plasma-desktop-$pkgver.tar.xz"
+source="https://download.kde.org/stable/plasma/$pkgver/plasma-desktop-$pkgver.tar.xz
+ revert-fix-jagginess-for-activities-list-icons.patch"
subpackages="$pkgname-dev $pkgname-doc $pkgname-lang knetattach"
options="!check" # Requires running dbus
@@ -86,4 +87,5 @@ knetattach() {
cd "$builddir"/build/knetattach
DESTDIR="$subpkgdir" make install
}
-sha512sums="c910be6bf63091f14f190e8fbfbd0039aa175d30f7a6870dbd99ffc3ff49a0f77e63e2d3fc9319dab1c650b15108cdaefee470eddab1213afe8d3a149ac64dd4 plasma-desktop-5.17.5.tar.xz"
+sha512sums="c910be6bf63091f14f190e8fbfbd0039aa175d30f7a6870dbd99ffc3ff49a0f77e63e2d3fc9319dab1c650b15108cdaefee470eddab1213afe8d3a149ac64dd4 plasma-desktop-5.17.5.tar.xz
+e4c84c37788bdc0f98f2b6c45ca497a3f8eac5b948ddf034c40ee12af0d1ac88d3ebf64dd146936f4f0f1b295c7fa7f3cd2854f85e2ec3dd546a8ccc716f3bdd revert-fix-jagginess-for-activities-list-icons.patch"
diff --git a/community/plasma-desktop/revert-fix-jagginess-for-activities-list-icons.patch b/community/plasma-desktop/revert-fix-jagginess-for-activities-list-icons.patch
new file mode 100644
index 0000000000..cc3232ccfa
--- /dev/null
+++ b/community/plasma-desktop/revert-fix-jagginess-for-activities-list-icons.patch
@@ -0,0 +1,33 @@
+From 1db4d07bb78858da7676720d13ee7c4f3bd8e6e0 Mon Sep 17 00:00:00 2001
+From: Nate Graham <nate@kde.org>
+Date: Sun, 12 Jan 2020 08:39:29 -0700
+Subject: Revert "[KCMs/Activities] Fix jagginess for activities list icons on
+ high DPI systems"
+
+This reverts commit 567f71714faac305947573e307f486a9960cf1d1.
+
+The commit in question was pushed without review and should not have
+been. It worked fine for me in local testing but somehow was broken
+anyway. Sorry. :(
+
+BUG: 416158
+---
+ kcms/activities/qml/activitiesTab/ActivitiesView.qml | 2 --
+ 1 file changed, 2 deletions(-)
+
+diff --git a/kcms/activities/qml/activitiesTab/ActivitiesView.qml b/kcms/activities/qml/activitiesTab/ActivitiesView.qml
+index 531ef9f..aac13a2 100644
+--- a/kcms/activities/qml/activitiesTab/ActivitiesView.qml
++++ b/kcms/activities/qml/activitiesTab/ActivitiesView.qml
+@@ -52,8 +52,6 @@ ColumnLayout {
+ height: Kirigami.Units.iconSizes.medium
+ width: height
+ source: model.icon
+- sourceSize.width: model.icon.width
+- sourceSize.height: model.icon.height
+ }
+
+ QQC2.Label {
+--
+cgit v1.1
+