aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorrahmanshaber <rahmanshaber@yahoo.com>2019-07-29 12:10:10 +0800
committerLeo <thinkabit.ukim@gmail.com>2019-07-29 03:58:53 -0300
commit1f9f1d76fec3cdab99118174583c4d34ebe8d124 (patch)
tree3d6b8158eefba83100b9a4adfa263e0891f138bb
parent7ed89566a50de557481b89b8be41cb0161f71260 (diff)
downloadaports-1f9f1d76fec3cdab99118174583c4d34ebe8d124.tar.bz2
aports-1f9f1d76fec3cdab99118174583c4d34ebe8d124.tar.xz
testing/libarchive-qt: new aport
-rw-r--r--testing/libarchive-qt/APKBUILD25
1 files changed, 25 insertions, 0 deletions
diff --git a/testing/libarchive-qt/APKBUILD b/testing/libarchive-qt/APKBUILD
new file mode 100644
index 0000000000..99cdc9677b
--- /dev/null
+++ b/testing/libarchive-qt/APKBUILD
@@ -0,0 +1,25 @@
+pkgname=libarchive-qt
+pkgver=1.0.2
+pkgrel=0
+pkgdesc="A Qt based archiving solution with libarchive backend"
+arch="all"
+url="https://gitlab.com/marcusbritanicus/libarchive-qt"
+license="LGPL-3.0-or-later"
+depends_dev="qt5-qtbase-dev xz-dev libarchive-dev zlib-dev bzip2-dev"
+makedepends="$depends_dev lzip"
+source="$pkgname-$pkgver.tar.gz::https://gitlab.com/marcusbritanicus/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz"
+subpackages="$pkgname-dev"
+builddir="$srcdir/$pkgname-v$pkgver"
+options="!check"
+
+build() {
+ cd "$builddir"
+ qmake-qt5
+ make
+}
+
+package() {
+ cd "$builddir"
+ INSTALL_ROOT="$pkgdir" make install
+}
+sha512sums="3d06beff6f23ec16dfcd3b18e5ade63f22568b7466a539750d916e73be24dac6e4d9551865eea960d2c2745639bd68ae6906d13a3066cc02c8056da44be9f6a2 libarchive-qt-1.0.2.tar.gz"