aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Polański <michal@polanski.me>2020-03-23 22:47:48 +0100
committerMichał Polański <michal@polanski.me>2020-03-23 22:47:48 +0100
commit1faefae5c6cd6fbb85509bcfc19a6938d9cd12b5 (patch)
tree659904bf5bdb8301c26bbeb2809dda04899c6014
parent8e6a5b80ac441e051456ea6860cb1adc5c390bfe (diff)
downloadaports-1faefae5c6cd6fbb85509bcfc19a6938d9cd12b5.tar.bz2
aports-1faefae5c6cd6fbb85509bcfc19a6938d9cd12b5.tar.xz
testing/wev: new aport
-rw-r--r--testing/wev/APKBUILD23
1 files changed, 23 insertions, 0 deletions
diff --git a/testing/wev/APKBUILD b/testing/wev/APKBUILD
new file mode 100644
index 0000000000..1b27b4c71d
--- /dev/null
+++ b/testing/wev/APKBUILD
@@ -0,0 +1,23 @@
+# Contributor: Michał Polański <michal@polanski.me>
+# Maintainer: Michał Polański <michal@polanski.me>
+pkgname=wev
+pkgver=1.0.0
+pkgrel=0
+pkgdesc="Wayland event viewer"
+url="https://git.sr.ht/~sircmpwn/wev"
+arch="all"
+license="MIT"
+makedepends="wayland-dev wayland-protocols libxkbcommon-dev scdoc"
+options="!check" # no test suite
+subpackages="$pkgname-doc"
+source="$pkgname-$pkgver.tar.gz::https://git.sr.ht/~sircmpwn/wev/archive/$pkgver.tar.gz"
+
+build() {
+ make
+}
+
+package() {
+ make DESTDIR="$pkgdir" PREFIX=/usr MANDIR=/usr/share/man install
+}
+
+sha512sums="81e837b9b9afda04bafbc7387d839c1ef84aeb5742a4c152dbfadebeb0ef511d55a053c9a741045af7d48473f0561d7d4f39f999ebc9d77480178d6fa72b8d03 wev-1.0.0.tar.gz"