aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 08:48:58 +0000
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-02-05 08:48:58 +0000
commit20b54c1dd8778e099be80aa59ee5e278ff57e1b0 (patch)
tree054c352ae3a6c108b6e2952a96c32291b6b9e359
parentc4672fd3c73c7ce7d5539b2509e0a54771473368 (diff)
downloadaports-20b54c1dd8778e099be80aa59ee5e278ff57e1b0.tar.bz2
aports-20b54c1dd8778e099be80aa59ee5e278ff57e1b0.tar.xz
testing/curlftpfs: attempt to fix build on ppc64le and aarch64
-rw-r--r--testing/curlftpfs/APKBUILD13
1 files changed, 11 insertions, 2 deletions
diff --git a/testing/curlftpfs/APKBUILD b/testing/curlftpfs/APKBUILD
index 1e13c16969..b6075b3a11 100644
--- a/testing/curlftpfs/APKBUILD
+++ b/testing/curlftpfs/APKBUILD
@@ -2,7 +2,7 @@
# Maintainer: Milan P. Stanić <mps@arvanta.net>
pkgname=curlftpfs
pkgver=0.9.2
-pkgrel=0
+pkgrel=1
pkgdesc="Fuse mount FTP server"
url="https://sourceforge.net/projects/curlftpfs/"
arch="all"
@@ -23,9 +23,18 @@ source="https://downloads.sourceforge.net/project/curlftpfs/curlftpfs/0.9.2/curl
builddir="$srcdir/${pkgname}-${pkgver}"
patch_args="-p1"
+prepare() {
+ default_prepare
+ update_config_sub
+}
+
build() {
cd "$builddir"
- ./configure --prefix=/usr
+ ./configure \
+ --build=$CBUILD \
+ --host=$CHOST \
+ --target=$CTARGET \
+ --prefix=/usr
make CFLAGS="-I/usr/include/fuse -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -D__off_t=off_t -D_FILE_OFFSET_BITS=64"
}