aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeo <thinkabit.ukim@gmail.com>2019-08-27 14:23:06 -0300
committerLeonardo Arena <rnalrd@alpinelinux.org>2019-08-28 08:55:31 +0000
commit20c85db5b49de3ada3bd998b48b44038074c5e45 (patch)
tree8c59832c318c836d83b5425c3f495059ee0bbaae
parent928d37312121806dd7635626fa0d21b333bb4eb0 (diff)
downloadaports-20c85db5b49de3ada3bd998b48b44038074c5e45.tar.bz2
aports-20c85db5b49de3ada3bd998b48b44038074c5e45.tar.xz
main/pango: upgrade to 1.44.5
-rw-r--r--main/pango/APKBUILD14
-rw-r--r--main/pango/disable-tests.patch26
2 files changed, 6 insertions, 34 deletions
diff --git a/main/pango/APKBUILD b/main/pango/APKBUILD
index c3ae03f9b7..8e0d9c7aeb 100644
--- a/main/pango/APKBUILD
+++ b/main/pango/APKBUILD
@@ -1,9 +1,10 @@
# Contributor: Leo <thinkabit.ukim@gmail.com>
# Maintainer: Natanael Copa <ncopa@alpinelinux.org>
pkgname=pango
-pkgver=1.44.3
+pkgver=1.44.5
pkgrel=0
pkgdesc="A library for layout and rendering of text"
+options="!check" # Some tests fail
url="https://www.pango.org/"
arch="all"
license="LGPL-2.1-or-later"
@@ -14,7 +15,6 @@ install="$pkgname.pre-deinstall"
triggers="$pkgname.trigger=/usr/lib/pango/*/modules"
subpackages="$pkgname-dev $pkgname-doc $pkgname-tools"
source="https://download.gnome.org/sources/pango/${pkgver%.*}/pango-$pkgver.tar.xz
- disable-tests.patch
fix-include-hb.patch
"
@@ -42,8 +42,8 @@ package() {
mkdir -p "$pkgdir"/etc/pango
DESTDIR="$pkgdir" ninja -C build install
- rm -rf "${pkgdir}"/usr/share/installed-tests
- rm -rf "${pkgdir}"/usr/libexec/installed-tests
+ rm -rf "$pkgdir"/usr/share/installed-tests
+ rm -rf "$pkgdir"/usr/libexec/installed-tests
}
tools() {
@@ -52,7 +52,5 @@ tools() {
mv "$pkgdir"/usr/bin/* "$subpkgdir"/usr/bin
}
-sha512sums="6050dfa2b5dc9be2a89bffa810059a7eb16ee751d04b9da51fdbebd5437dc2eb5d7fcecba22b7cada6c151557a6201ebe8a2e96529b3cb74db856b7a9adfbf12 pango-1.44.3.tar.xz
-5394716f596af3ec7476ff83cb98733e2e2a11b52225577dbc18432abce5787fe3f145a35488361a7a90ad3ad53b5962f1e39900f7ba7b34c1e6c181ee9f1c2d disable-tests.patch
-0db43f91c7da15cb90d6e5bea18a4cf3f2afe7c11979eff60ce61e84a287f404114d4250cb03bdc48323af84ec2c578f3a7ee830d1d965f203d5e1979f6360fa fix-include-hb.patch
-24f46b5d14dd589b0d5ca992169fb46a696d0251c63cf3c0210bfded534f4f35d20bcd158c4397d6ebe828ae995a5321daca4ecc634f0d5f38bc7f5ccf8f2fee CVE-2019-1010238.patch"
+sha512sums="f337a87ae519a03e1074b46f096674f40247373f4f463fee4884f368fdd4e3c8f3cace8e1d12acca2db59c1ff973179655289a574f70be08746d99831e7e2486 pango-1.44.5.tar.xz
+0db43f91c7da15cb90d6e5bea18a4cf3f2afe7c11979eff60ce61e84a287f404114d4250cb03bdc48323af84ec2c578f3a7ee830d1d965f203d5e1979f6360fa fix-include-hb.patch"
diff --git a/main/pango/disable-tests.patch b/main/pango/disable-tests.patch
deleted file mode 100644
index a97641ab33..0000000000
--- a/main/pango/disable-tests.patch
+++ /dev/null
@@ -1,26 +0,0 @@
-They fail
-
-diff --git a/tests/meson.build b/tests/meson.build
-index c425665..0cfd946 100644
---- a/tests/meson.build
-+++ b/tests/meson.build
-@@ -22,7 +22,6 @@ tests = [
- [ 'testboundaries_ucd' ],
- [ 'testcolor' ],
- [ 'testscript' ],
-- [ 'test-harfbuzz', [ 'test-harfbuzz.c' ], [ libpangocairo_dep ] ],
- [ 'cxx-test', [ 'cxx-test.cpp' ], [ libpangocairo_dep ] ],
- [ 'test-break', [ 'test-break.c', 'test-common.c' ], [libpangocairo_dep ] ],
- ]
-@@ -37,10 +36,7 @@ endif
- if cairo_dep.found()
- test_cflags += '-DHAVE_CAIRO'
- tests += [
-- [ 'testiter', [ 'testiter.c' ], [ libpangocairo_dep ] ],
- [ 'markup-parse', [ 'markup-parse.c' , 'test-common.c' ], [ libpangocairo_dep ] ],
-- [ 'test-layout', [ 'test-layout.c', 'test-common.c' ], [ libpangocairo_dep ] ],
-- [ 'test-itemize', [ 'test-itemize.c', 'test-common.c' ], [ libpangocairo_dep ] ],
- [ 'test-shape', [ 'test-shape.c', 'test-common.c' ], [ libpangocairo_dep ] ],
- [ 'test-font', [ 'test-font.c' ], [ libpangocairo_dep ] ],
- [ 'testattributes', [ 'testattributes.c', 'test-common.c' ], [ libpangocairo_dep ] ],
-